Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
Hello, I have installed a program that is based on Xemacs, so I had to install xemacs too... however, I seem to be missing something because I get the following ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13

    XEmacs Problem


    Hello,

    I have installed a program that is based on Xemacs, so I had to install xemacs too... however, I seem to be missing something because I get the following error:

    Code:
    (warning/warning) X-Symbol: cannot deduce default encoding, I'll assume 'iso-8859-1'
    Thanks for your help,
    Jenny

  2. #2
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi jenny_psion,
    Add this line to the beginning of .emacs file in your home directory (i.e., ~/.emacs) : -
    (setq x-symbol-default-coding 'iso-8859-1)
    Try doing this and - just to know - can you post the output of the following command : -
    $ locale -ck code_set_name charmap
    With Regards,
    Thinker

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Hello,

    Thanks for your reply.
    I just wanted to try to do what you said, but I cannot find a file called .emacs anywhere.
    Could you please let me know where I can find it? (I have done a search already)

    Thanks,
    Jenny

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    If it doesn't exist, then create it in your home directory and make the changes that Thinker specified.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  6. #5
    Linux Enthusiast
    Join Date
    Aug 2005
    Location
    Hell
    Posts
    514
    Quote Originally Posted by Thinker
    Hi jenny_psion,
    Add this line to the beginning of .emacs file in your home directory (i.e., ~/.emacs) : -

    Try doing this and - just to know - can you post the output of the following command : -


    With Regards,
    Thinker
    But Emacs and XEmacs are completely different programs.

  7. #6
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi spoon!,
    But Emacs and XEmacs are completely different programs.
    XEmacs and GNU Emacs are NOT completely different programs, they are very much related.

    .emacs used to be the initialization file for customizing XEmacs according to the user's preferences.

    Hi jenny_psion,
    I just wanted to try to do what you said, but I cannot find a file called .emacs anywhere.
    Could you please let me know where I can find it? (I have done a search already)
    Till version 21.4 of XEmacs, ~/.emacs used to be the init file for XEmacs and starting from version 21.4, it is ~/.xemacs/init.el

    Which version of XEmacs do you use? If you are using XEmacs version 21.4 or better, then you can add the line that I mentioned earlier to ~/.xemacs/init.el file.

    Even in the new version, you can use ~/.emacs, but for the first time when you run XEmacs it will ask you to migrate the file to the new location and if you select YES to do that, then the file will be moved and a compatible .emacs file will be placed in home directory, so that you run old versions of XEmacs and GNU Emacs.

    With Regards,
    Thinker

  8. #7
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Hi!,

    Thanks for all your help.
    I am using xemacs 21.4.0 . I have just done a search for the file .init.el, however, this file also wasn't found.
    Should I create the file in my xemacs-21.4 directory (which is located in /home/jen/), or should I create it in /home/jen?

    I typed that "locale -ck code_set_name "etc and the output I get is:

    Code:
    LC_CTYPE
    charmap="UTF-8"
    Thank you,
    Jenny

  9. #8
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi jenny_psion,
    Quote Originally Posted by jenny_psion
    I am using xemacs 21.4.0 . I have just done a search for the file .init.el, however, this file also wasn't found.
    Should I create the file in my xemacs-21.4 directory (which is located in /home/jen/), or should I create it in /home/jen?

    I typed that "locale -ck code_set_name "etc and the output I get is:
    Code:
    LC_CTYPE
    charmap="UTF-8"
    Did you search for .init.el? It is init.el and you should find it in ~/.xemacs/ directory.

    With Regards,
    Thinker

  10. #9
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Hello,

    I havent got an .xemacs directory.
    Where would that directory be? In my home folder? The only xemacs related folder I can find in my home directory is "xemacs-21.4.0".

    I have just searched for init.el, and also couldnt find that.

    Jenny

  11. #10
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi jenny_psion,
    Where would that directory be? In my home folder?
    .xemacs is a hidden directory. It should be in your home directory (~/).

    I get a different error:
    Code:
    Error in init file: Invalid read syntax: ")"
    Can you post the contents of .emacs file that you created?

    With Regards,
    Thinker

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •