Find the answer to your Linux question:
Results 1 to 3 of 3
I am trying to install IBM WebSphere Application Server 5.1, and it gives me the following erorr. InstallShield Wizard Initializing InstallShield Wizard... Searching for Java(tm) Virtual Machine... ..........................A suitable JVM ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    2

    cannot find suitable JVM


    I am trying to install IBM WebSphere Application Server 5.1, and it gives me the following erorr.

    InstallShield Wizard

    Initializing InstallShield Wizard...

    Searching for Java(tm) Virtual Machine...
    ..........................A suitable JVM could not be found. Please run the program again using the option -is:javahome <JAVA HOME DIR>

    java is already installed in /opt/j2re1.4.1_07 and I have installed application server before on the same machine and it worked with no errors.

    tried to type java -is:javahome

    Unrecognized option: -is
    Could not create the Java virtual machine.

    also tried to do ./install -is:javahome "/opt/j2re1.4.1_07/bin/"

    nothing worked. here is my environment variables, it looks fine too

    export PATH=/opt/j2re1.4.1_07/bin:$PATH
    export JAVA_HOME="/opt/j2re1.4.1_07"
    export JAVA_PATH="/opt/j2re1.4.1_07"
    export CLASSPATH=.:/opt/j2re1.4.1_07
    export JAVA="/opt/j2re1.4.1_07/bin/java"

    i added JAVA and JAVA_PATH to try it but didnt work

    Thanks in advance.

  2. #2
    Just Joined! bravobritto's Avatar
    Join Date
    Aug 2006
    Location
    Somewhere in India
    Posts
    23

    Smile

    I discovered that I also have this issue and I've been at it for the last few hours. I have clients waiting to run and this just refuses to work!

    According to Apple, the J2SE 5.0 Release 4 (4.0) is an update/add-on and does not change the standard Java 1.4.2 install.

    I ran the 5.0 control panel and set the default back to 1.4.2, but this had no effect...

    I have to figure that it's one of these two conditions:

    1. The QLA is looking for something Java-related that is no longer there (J2SE 5 changed something), or...

    2. The path used by the QLA to find this Java-related something has changed.

    I'll keep looking...QLA related commands you can try.

    Regards
    Britto

  3. #3
    Linux Engineer Thrillhouse's Avatar
    Join Date
    Jun 2006
    Location
    Arlington, VA, USA
    Posts
    1,377
    Quote Originally Posted by bravobritto
    According to Apple, the J2SE 5.0 Release 4 (4.0) is an update/add-on and does not change the standard Java 1.4.2 install.
    They might say this but I found that on my SUSE machine I had to remove the old 1.4.2 packages before I installed 5.0. I don't know which distro you're using but you might want to try doing that.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •