Find the answer to your Linux question:
Results 1 to 5 of 5
Well, I had a pretty good discrpiton of the problem typed out, but I accidently closed the browser window when I was trying my seccond problem again (I didn't know ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Location
    Ont. Canada
    Posts
    52

    Xorg problems


    Well, I had a pretty good discrpiton of the problem typed out, but I accidently closed the browser window when I was trying my seccond problem again (I didn't know that ctrl + alt + F4 closed a tab in Fire fox), so this one may not be as good. If there is something you don't understand, please let me know.

    Resolution

    My First probrem is with my screen resolution. I had my xorg.conf file open today helping a friend via AIM who accidently set his resolution too high, and was new to linux, so didn't know anything about the command line, and I decided I want to change my resolution (once we got his fixed). So, I reopend the file as root, and edited the Screen section to:

    Code:
    Section "Screen"
        Identifier  "Screen 1"
        Device      "VESA Framebuffer"
        Monitor     "My Monitor"
    
    # If your card can handle it, a higher default color depth (like 24 or 32)
    # is highly recommended.
    
    #   DefaultDepth 8
    #   DefaultDepth 16
       DefaultDepth 24
    #   DefaultDepth 32
    
    # "1024x768" is also a conservative usable default resolution.  If you
    # have a better monitor, feel free to try resolutions such as
    # "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
    # card/monitor can produce)
    
        Subsection "Display"
            Depth       8
            Modes "1280x1024" "1024x768" "800x600"
        EndSubsection
        Subsection "Display"
            Depth       16
            Modes "1280x1024" "1024x768" "800x600"
        EndSubsection
        Subsection "Display"
            Depth       24
            Modes "1280x1024" "1024x768" "800x600"
        EndSubsection
        Subsection "Display"
            Depth       32
            Modes "1280x1024" "1024x768" "800x600"
        EndSubsection
    
    EndSection
    Previously, the Modes were all set to "1024x768" "800x600" "640x480". I first only edited the 24 color depth subsecion, but when I restarted X, my resolution didn't change at all. So, I decided that I would change all of them, and see if I just edited the wrong one (I didn't think so, seing as how it is set above as DefalutDepth 24). So, I saved the file again, and restarted X. Still didn't change. Am I doing something wrong?

    Virtual Terminals
    Ever since I installed Slackware, I have never been able to access my virtual terminals from X. I didn't know why, but it never really bothered me too much (Of corse it bothered me some, but beings I couldn't get to them, I just used a terminal onmy desktop). Anyway, I really would like to be able to get to them. While I was in my xorg.conf flie today, I say a setting like this:

    Code:
    # Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
    # (where n is 1 through 12).  This allows clients to receive these key
    # events.
    
    #    Option     "DontVTSwitch"
    This really got me wondering: if xorg.conf says I should be able to access them, why can't I? It is just annoying.

    Thanks for your help in advance.

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Location
    Ont. Canada
    Posts
    52
    Not to be impatient, but can anybody help me? I posted this two days ago.

  3. #3
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Your Screen section lists a Device section named "VESA Framebuffer". Is there a "Device" section that has that identifier? That is, do you see this:
    Code:
    Section "Device"
        Identifier    "VESA Framebuffer"
        Driver        "nvidia"
    ...
    If not, make the names match. What Driver does the Device section use? My "Device" section lists Driver "radeon" on the machine that has an ATI card, and Driver "nvidia" on the machine that has a GeForce card.

    The Screen section selects a Device section by identifier, and the Device section picks the Driver by name. (I'm not positive how that driver name get's used to actually pick a driver file, but I think it's just nvidia.ko or radeon.ko.)

    Also, Look in the "Monitor" section at the "ModeLine" lines. The modes (e.g. "1280x1024") in the "Screen" section must match the modes in the "Monitor" section (or standard Vesa modes) or they won't be used.

    I was able to find a "Monitor" section to copy for my monitor with google.

    If X is satisfied that the monitor can handle more than one of the listed modes, you can switch between them with CTRL+ALT+Keypad-Plus and CTRL+ALT+Keypad-Minus. You can try that.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2006
    Location
    Ont. Canada
    Posts
    52
    my "Device" section uses the "vesa" driver"; my screen "Device" matches my device "Identifier", and my "Monitor" section doesn't have "Modeline" lines, it is just:

    Code:
    Section "Monitor"
    
        Identifier  "My Monitor"
    
        HorizSync   31.5 - 50.0
    
        VertRefresh 40-90
    
    EndSection

  6. #5
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    It looks like you are using the generic vesa driver. If you want to use higher resolution I believe you will have to use a driver specific for you hardware, which is probably either ATI or nVidia. You first need to figure out what hardware you have. GeForce is nVidia, Radeon is ATI. The video card itself may be manufactured by a third party (e.g. Asus), which is irrelevant.

    I don't know what Slackware has, but they may have a video driver package for your hardware. If not, if you have an nVidia card, you can download the driver here. As root run
    sh NVIDIA-Linux-x86-1.0-876-pkg1.run
    or similar, which will install the driver and create an appropriate xorg.conf file for you. You have to have the kernel sources installed.

    I'm not sure what the state of ATI drivers is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •