Find the answer to your Linux question:
Results 1 to 7 of 7
I downloaded mplayer, and it plays all the other codecs fine. but wmv, just cant be played. when i open it in mplayer it says "Error opening/inializing the selected video_out(-vo) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Content Team
    Join Date
    Jul 2006
    Posts
    37

    Arch Linux Mplayer wont player .wmv


    I downloaded mplayer, and it plays all the other codecs fine. but wmv, just cant be played. when i open it in mplayer it says "Error opening/inializing the selected video_out(-vo) device" and if i open it up with firefox, i just get wierd colored blocks. I downloaded the essential codecs from mplayers website and put them in the correct folder, but that didnt do anything.

  2. #2
    Content Team
    Join Date
    Jul 2006
    Posts
    37
    i changed drivers, and now mplayer will open the .wmv, but it will still be just a bunch of yellow blocks.

  3. #3
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Maybe installing the all-codecs package or unsupported?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  4. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I don't run mplayer so can't say for sure what the problem might be but try running:

    Code:
    pacman -S codecs
    oz

  5. #5
    Content Team
    Join Date
    Jul 2006
    Posts
    37
    tried that, wont work. it just has random yellow and green squares moving around.

  6. #6
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1

    possibly your driver???

    Open the .mplayer/gui.conf file the vo_driver line should read: vo_driver = "x11"

    If that doesn't work, check your video card support for mplayer @ http://www.mplayerhq.hu/DOCS/HTML-si...ml#video-cards and follow the instructions for your card.

    Best of luck to you.

  7. #7
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    A possibility is, that the wmv file you try to open relies on a too new version of the wmv codec that didn't get ported to linux yet.
    Windows free since 2002 | computing since 1984

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •