Find the answer to your Linux question:
Results 1 to 6 of 6
┌─(forgotten@lha2ms)─ └─(~/tars/thunderbird)─ ./thunderbird-bin ./thunderbird-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory This is what i get when trying to run thunderbird ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! forgottentq's Avatar
    Join Date
    Jun 2006
    Location
    Virginia at the moment.
    Posts
    46

    Mozilla Firefox/Thunderbird Shared Lib. Problem.


    ┌─(forgotten@lha2ms)─
    └─(~/tars/thunderbird)─ ./thunderbird-bin
    ./thunderbird-bin: error while loading shared libraries: libmozjs.so: cannot open shared object file: No such file or directory


    This is what i get when trying to run thunderbird from the command line.. I googled it and this link https://bugzilla.mozilla.org/show_bug.cgi?id=312360 tells me that it's a LD_LIBRARY_PATH problem.. saying that it only includes a relative path instead of absolute.. so anyone that runs firefox and or thunderbird from a personal directory gets screwed.. But it's says this only happens after running the "updater" which i havn't done.. it just did it by itself..

    My problem is that i don't know where to set the LD_LIBRARY_PATH to include an absolute path... Is it simple an entry in your .bashrc ? if so i already tried that without any luck.

    Any help would be GREATLY appreciated.

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    It's an environment variable, so you should just need to set it in ~/.bashrc and then export it:
    Code:
    export LD_LIBRARY_PATH=/foo/bar
    Alternatively, it may be that the command 'thunderbird' is actually a script that sets some variables then runs the binary. Check and make sure. If it is a script, you can just modify the script to use an absolute path.

  3. #3
    Just Joined! forgottentq's Avatar
    Join Date
    Jun 2006
    Location
    Virginia at the moment.
    Posts
    46
    thanx that fixed it.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! forgottentq's Avatar
    Join Date
    Jun 2006
    Location
    Virginia at the moment.
    Posts
    46
    cept now for some reason it says my server refuses to connect thru pop3 (110).. even tho it brought up my exact settings from my ~/.thunderbird/ profile that i havn't modified at all lol.. i'm just havin a stroke of very bad luck i guess.

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi forgottentq !!!

    Quote Originally Posted by forgottentq
    it says my server refuses to connect thru pop3 (110)..
    if you are using gmail then security settings should be SSL... use port 995 not 110...

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined! forgottentq's Avatar
    Join Date
    Jun 2006
    Location
    Virginia at the moment.
    Posts
    46
    I'm connecting to a local Exchange 5.5 Server. Everything worked fine before.. i just don't understand.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •