Find the answer to your Linux question:
Results 1 to 9 of 9
Hi! I have just installed fc4 on my desktop but I can't update yum. When I enter # yum update I get a message saying there is an error accecing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5

    updating yum


    Hi! I have just installed fc4 on my desktop but I can't update yum. When I enter
    # yum update

    I get a message saying there is an error accecing /etc/yum.conf. Please also help me get mp3 playing on my machine.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi mckay !!!

    I get a message saying there is an error accecing /etc/yum.conf.
    if you getting "permission denied" error... it means you are not logged in as root...
    on terminal type
    $ su -
    enter root password
    $ yum update

    if this is not the reason, post error message here.....

    Please also help me get mp3 playing on my machine
    $ yum -y xmms xmms-mp3

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    Halo Casper!

    Thanx for your help.

    I did log in as root and when I enter the update command, this is what I get

    Config Error: Error accessing file for config file:///etc/yum.conf

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    post the contents of /etc/yum.conf

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    I went into the etc directory and listed the contents, but could not find a file called yum.conf. I could only find yum, yum.conf.bak and yum.repos.d.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi mckay !!!

    where is yum.conf ???
    you have yum.conf.bak file.. it means yum.conf file was edited and removed...
    rename yum.conf.bak file with yum.conf...

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    Okay, I remember following instructions from one link where I moved yum.conf to yum.conf.bak, so I have reversed to process and now I have the yum.conf file back. The update is active and I get this response:

    You have enabled checking of packages via GPG keys. This is a good thing.
    However, you do not have any GPG public keys installed. You need to download
    the keys for packages you wish to install and install them.
    You can do that by running the command:
    rpm --import public.gpg.key


    Alternatively you can specify the url to the key you would like to use
    for a repository in the 'gpgkey' option in a repository section and yum
    will install it for you.

    For more information contact your distribution or package provider.

    but when I enter the specified rpm command: rpm --import public.gpg.key
    I get the following response: error: public.gpg.key: import read failed(-1).

    I have also entered the command: yum -y install xmms-mp3
    I then get the response as the one above. So what do I do next?

  8. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    oh by the way, here are the contents of yum.conf:

    [dag]
    name=Dag RPM Repository for Fedora Core
    baseurl=http://apt.sw.be/fedora/$releasever/en/$basearch/dag
    gpgcheck=1
    enabled=1

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi mckay !!

    these are the default contents of yum.conf file.....

    [main]
    cachedir=/var/cache/yum
    keepcache=0
    debuglevel=2
    logfile=/var/log/yum.log
    pkgpolicy=newest
    distroverpkg=redhat-release
    tolerant=1
    exactarch=1
    obsoletes=1
    gpgcheck=1
    plugins=1
    metadata_expire=1800

    # PUT YOUR REPOS HERE OR IN separate files named file.repo
    # in /etc/yum.repos.d
    you set dag repo in yum.conf.... it should be in in a separate file in yum.repos.d....
    dag is giving GPG error......download rpmforge-release. actually its for FC3, there is nothing for FC4 or 5 in dags but i suppose they support FC5 too...
    before doing any thing, i suggest you to read this article... look for yum....
    copy the contents i posted and paste in yum.conf......
    you should have fedors-core.repo, fedors-extera.repo and fedors-update.repo files in /etc/yum.repos.d folder......

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •