I am a newbie but I don't think this is a newbie problem. I seem to know what I am doing and I have come to a huge bump in the road. I am now at the last stage of trying to use PHP5 with Apache2. I guess I got a weak distro (MEPIS) with few compilers. I had to grab byacc, flex, and bison just to get PHP5 and Apache2 to compile. I am just going to post my compile settings for the two and please see if I missed something because I can not figure it out. When I go to restart Apache2 I get this error message:

./apachectl -k restart
Syntax error on line 232 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp5.so into server: /usr/local/apache2/modules/libphp5.so: undefined symbol: zend_register_list_destructors_ex
Here is my configure settings for Apache2:

./configure --enable-so
I realized I had to enable DSO for PHP5 to work with it. I know I have the proper directives in my httpd.conf setup file to load PHP5. Here it is as follows:

...
LoadModule php5_module modules/libphp5.so
...
AddType application/x-httpd-php .php
Apache2 works fine ONLY if I comment out the LoadModule line. Here is my configure settings when I compiled PHP5:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --enable-sockets --with-config-file-path=/usr/local/lib --enable-ftp --with-zlib --with-openssl --enable-exif --with-gd --enable-memory-limit --with-libxml --with-pic --with-jpeg --enable-calendar --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-trans-sid --enable-bcmath --with-bz2 --enable-gd-native-ttf
I also downloaded the Zend Optimizer and followed its installation instructions. I then recompiled PHP5 using the above settings and I am still getting the error message from Apache2. Here is the php.ini file settings for Zend:

[Zend]
zend_extension_manager.optimizer=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
zend_optimizer.version=3.0.1

zend_extension=/usr/local/Zend/lib/Optimizer-3.0.1/php-5.1.x/ZendOptimizer.so
zend_extension_ts=/usr/local/Zend/lib/Optimizer_TS-3.0.1/php-5.1.x/ZendOptimizer.so
zend_optimizer.optimization_level=15
Also I put php.ini in the folder path that I specified during configure, as noted above.

Sorry, this is long but I am trying to provide as much information as possible. I have tried to Google the solution for hours now and I come up with nothing.

Thank you for any help,
Shawn W

...............
...............

I actually just ran 'make clean ' on php-5.1.6. Then I installed php-5.1.4 and it seems to work now. I guess 5.1.6 is bugged. Unforntunatly, I am still having problems parsing xml dom functions. I installed libxml2-2.6.26 before installing php and I added the --with-libxml argument to the php ./configure command. This is so aggrivating. Any advice on this would be great too.

Thank you,
Shawn W