Find the answer to your Linux question:
Results 1 to 2 of 2
There is no problem of playing of sound in my computer but when it comes to recording. alsamixer does not work giving the following error message Code: alsamixer: function snd_ctl_open ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Location
    Assam, India
    Posts
    36

    Sound Problem


    There is no problem of playing of sound in my computer but when it comes to recording.

    alsamixer does not work giving the following error message
    Code:
    alsamixer: function snd_ctl_open failed for default: No such device
    and amixer does not work
    Code:
    amixer: Mixer attach default error: No such device
    I tried recording with KRecord. It shows that it is recording but the file just recorded is blank, without any sound.

    aumix does not have any problem and I can control the playback volume but in aumix there is no bar for adjusting the left-right balance of the microphone.

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    13
    Try running 'pkgtool' and go to setup. Configure that, reboot, and see if that works. I don't know, I might be wrong, but it worked for me when I got the error for alsamixer. I hope that helps!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •