Find the answer to your Linux question:
Results 1 to 5 of 5
This is probably somethign simple but it's driving me nuts. I am running Debian 3.1 and have installed the ImageMagick package via apt-get just to test a few things. No ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    NSH
    NSH is offline
    Just Joined!
    Join Date
    Sep 2006
    Posts
    3

    ImageMagick


    This is probably somethign simple but it's driving me nuts.

    I am running Debian 3.1 and have installed the ImageMagick package via apt-get just to test a few things. No matter what I do I can't get a php script to find the convert app. It drops to exec to run convert and it can't seem to find it.

    The path is /usr/bin and convert exists there. I have tried making a simlink to the /usr/bin directory from /var/www/...... directory where my website sits.
    I have full control over the box and I have tried changing owner of the app, etc.

    I have scoured the net but can't find anything that seems to point me in the right direction.

    Any help is appreciated.

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    The webserver user maybe doesn't have the $PATH configured. Try using the full path to convert: /usr/bin/convert, instead of just 'convert'.

  3. #3
    NSH
    NSH is offline
    Just Joined!
    Join Date
    Sep 2006
    Posts
    3
    I am actually attempting to use an app. The app does in fact use the full path and it still can't seem to find the file

  4. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    What is the exact error message you get? Also, what user/group does the script run under? What is the output of the command 'ls -l /usr/bin/convert'?

  5. #5
    NSH
    NSH is offline
    Just Joined!
    Join Date
    Sep 2006
    Posts
    3
    # ls -l /usr/bin/convert
    -rwxr-xr-x 1 root root 4644 2006-01-28 15:39 /usr/bin/convert

    The php app is calling convert and reports that it does not find it.
    I did a quick check with a

    echo exec("/usr/bin/convert");

    This outputs: " '-' for standard input or output " which is actually the last line of text if you run convert with no switches from a prompt. This tells me that the webserver can get to the convert binary. I am not sure why the other app can't.


    Thanks for the help in this. If you have other suggestions I am all ears.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •