Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
I keep getting a missing dependency for Java: Error: Missing Dependency: jdk = 2000:1.5.0_09-fcs is needed by package java-1.5.0-sun-compat In the past, when I get Java installed and working correctly, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! ctt1wbw's Avatar
    Join Date
    Jan 2005
    Location
    Maysville NC
    Posts
    58

    Problems installing Java


    I keep getting a missing dependency for Java:

    Error: Missing Dependency: jdk = 2000:1.5.0_09-fcs is needed by package java-1.5.0-sun-compat


    In the past, when I get Java installed and working correctly, every time I do a yum update, I keep getting this error and the system update stops. Where can I get this file?

  2. #2
    Banned
    Join Date
    Jul 2004
    Posts
    947
    What distro, running what command?

  3. #3
    Just Joined! ctt1wbw's Avatar
    Join Date
    Jan 2005
    Location
    Maysville NC
    Posts
    58
    Im using Fedora Core 5.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    I have the same problem.

    It is as if jpackage.org provided bogus information. I'm not too familiar with dependeicy formats, but the jdk one certainly looks different:

    # yum deplist java-1.5.0-sun-compat
    ....
    dependency: /usr/bin/ttmkfdir
    provider: ttmkfdir.x86_64 3.0.9-19.2.1
    dependency: /usr/bin/find
    provider: findutils.x86_64 1:4.2.27-4
    dependency: jdk = 2000:1.5.0_09-fcs
    Unsatisfied dependency
    dependency: /bin/sh
    provider: bash.x86_64 3.1-6.2
    dependency: config(java-1.5.0-sun-compat) = 1.5.0.09-1jpp
    provider: java-1.5.0-sun-compat.noarch 1.5.0.09-1jpp
    ...

    Note: I have jdk-1.5.0_09-fcs installed and the installation of java-1.5.0-sun-compat, completed successfully.

    Where is this "jdk = 2000:1.5.0_09-fcs" coming from?

    Thanks in advance.

  6. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    This come from the installed rpm file.

    # rpm -q --requires java-1.5.0-sun-compat-1.5.0.09-1jpp
    /bin/sh
    /bin/sh
    /bin/sh
    /bin/sh
    /usr/bin/find
    /usr/bin/perl
    /usr/bin/ttmkfdir
    /usr/bin/xsltproc
    /usr/sbin/chkfontpath
    /usr/sbin/update-alternatives
    config(java-1.5.0-sun-compat) = 0:1.5.0.09-1jpp
    jdk = 2000:1.5.0_09-fcs
    jpackage-utils >= 0:1.5.38
    mktemp
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(VersionedDependencies) <= 3.0.3-1

    Anyone knows what the 2000 in 2000:1.5.0_09-fcs is supposed to do?

  7. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1
    Hi guys...

    i had the same problem and solved it by just removing the java-1.5.0-sun-compat package... right now im updating and will probably install the package again after finishing

    tell me if it worked out for u

  8. #7
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    removing the compat rpm unregisters the sun jvm. it then defaults back to the older jvm bundled with fedora

  9. #8
    Just Joined!
    Join Date
    Oct 2006
    Posts
    11
    Hello,
    Trying to install java yesterday I got the error. I am also unsing Fedora Core 5.
    Did you fox the problem ?
    If yes could you please tell what you did ?
    thanks

  10. #9
    Just Joined!
    Join Date
    Oct 2006
    Posts
    11
    I got the problem when I tried to install java following the instructions given here:
    http://www.fedorafaq.org/#java.

    As proposed I downloaded the file:
    jdk-1_5_0_08-linux-i586-rpm.bin.
    But in the error message: " .... 2000:1.5.0_09-fcs ... ", it seems that
    it refers to version 9.
    So I downloaded the file:
    jdk-1_5_0_09-linux-i586-rpm.bin.
    Now the command:
    yum --enablerepo=jpackage-generic-nonfree install java-1.5.0-sun-compat,
    works well.

  11. #10
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    Thankd for the followup.

    Yeah that works for me too. The issue comes up only when I try to install something later on that depends on java. For instance, xml-commons-apis.

    you can also see the problem if you run
    yum deplist java-1.5.0-sun-compat-1.5.0.09-1jpp

    it says the the jdk dependency is not resolved.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •