Find the answer to your Linux question:
Results 1 to 9 of 9
everytime i try to use k3b to burn a dvd it gives me a fatal error and says input/ouput error what does this mean and how do i fix it??...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User gassman's Avatar
    Join Date
    Jan 2005
    Location
    Midwest USA
    Posts
    292

    k3b i/o error


    everytime i try to use k3b to burn a dvd it gives me a fatal error and says input/ouput error what does this mean and how do i fix it??
    If we couldn't laugh we would all go insane--Jimmy Buffett


    Registered Linux user # 376962

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    After the failure, look at the "debugging output" (there is a button for that in K3B during the burning) and post it here for more help.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Linux User gassman's Avatar
    Join Date
    Jan 2005
    Location
    Midwest USA
    Posts
    292
    i originally thought about posting it but it didnt show me anything that i thought would be helpfull anways here it is:
    Code:
    System
    -----------------------
    K3b Version: 0.12.14
    
    KDE Version: 3.5.1 Level "a" 
    QT Version:  3.3.5
    Kernel:      2.6.16.13-4-default
    Devices
    -----------------------
    LITE-ON DVDRW LDW-411S FS0H (/dev/hdg, ) at  [CD-R; CD-RW; CD-ROM; DVD-ROM; DVD-RW; DVD+R; DVD+RW] [DVD-ROM; DVD-R Sequential; DVD-RW Restricted Overwrite; DVD-RW Sequential; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R; Restricted Overwrite]
    
    LITE-ON LTR-48246S SGS3 (/dev/hdh, ) at  [CD-R; CD-RW; CD-ROM] [CD-ROM; CD-R; CD-RW] [SAO; TAO; RAW; SAO/R96P; SAO/R96R; RAW/R16; RAW/R96P; RAW/R96R]
    Used versions
    -----------------------
    growisofs: 6.1
    
    growisofs
    -----------------------
    Executing 'builtin_dd if=/home/eric/slackware-11.0-iso/slackware-11.0-install-dvd.iso of=/dev/hdg obs=32k seek=0'
    /dev/hdg: "Current Write Speed" is 1.0x1385KBps.
    :-[ WRITE@LBA=0h failed with SK=5h/ASC=64h/ACQ=00h]: Input/output error
    :-( write failed: Input/output error
    
    growisofs command:
    -----------------------
    /usr/bin/growisofs -Z /dev/hdg=/home/eric/slackware-11.0-iso/slackware-11.0-install-dvd.iso -use-the-force-luke=notray -use-the-force-luke=tty -dvd-compat -speed=1 -use-the-force-luke=bufsize:32m
    If we couldn't laugh we would all go insane--Jimmy Buffett


    Registered Linux user # 376962

  4. #4
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    226
    Try increasing the write speed. Some drives and media have a problem going as slow as 1X. Make sure you get something in the range that your media is rated for.

  5. #5
    Linux User gassman's Avatar
    Join Date
    Jan 2005
    Location
    Midwest USA
    Posts
    292
    I also found out that this drive will burn cdrw just fine but will not burn dvdrw
    If we couldn't laugh we would all go insane--Jimmy Buffett


    Registered Linux user # 376962

  6. #6
    Just Joined!
    Join Date
    Sep 2006
    Posts
    9
    ...first, be aware, that all of the GUI CD and CVD burning tools are just front ends to the command line tools (mkisofs, cdrtools look in k3b>options>programs for details).

    You can have problems, particularly writing to the various flavours of DVD, if the underlying tools are not reasonably up to date. So check your distro's update site and see if there have been updates to those tools.

    Another issue is that the various formats of DVD are really not the same, so you can find that, say, +RW works but -RW doesn't. (Your Liteon doesn't look to support -RAM; in some ways that's a mixed blessing as the RAM format has some advantages, but as RAM is the least used, it is probably the worst supported.)

    Another thing to check (sometimes goes wrong, but it doesn't look as if you've got that far yet) is that you've got enough space under /tmp. If you've not got enough, you'll get a crash when mkisofs tries to do its stuff.

    If you leave the speed on auto, it ought to sort it out automatically; it doesn't always work if there are issues with the underlying programs and you may have to specify a speed manually (and that doesn't always work, because if you specify a speed that k3b reckons is out of range it resets the speed, and this can happen because k3b hasn't understood the answer it gets back from the underlying programs, even if you've got the speed right and k3b has it wrong).

    And you can sometimes get errors back when k3b checks that the disc is blank; you may have to specify 'force'.

    As a last resort (all else having failed, bar reading the manual ), you could run k3b to try to get an idea of what command lines it would use, and then run similar commands (altering only the parameter you feel is the problem) from the command line. This does give you the ultimate in flexibility and control. But it is a bit of a pain...

  7. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    7
    I have exactly the same problem!
    And many others too, but I can't find a real answer anywere.
    Plz help me, or my new DVD-brander is useless to me.

  8. #8
    Linux User gassman's Avatar
    Join Date
    Jan 2005
    Location
    Midwest USA
    Posts
    292
    well budy if i could figure it out i would help you but i need to figure mine out first
    If we couldn't laugh we would all go insane--Jimmy Buffett


    Registered Linux user # 376962

  9. #9
    Just Joined!
    Join Date
    Aug 2006
    Posts
    7

    Lightbulb

    gassman, maybe it helps to check your system settings. (look if your dvd-drive is mounted right)
    I had these i/o errors too, I fixed it on this way. (I think)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •