Find the answer to your Linux question:
Results 1 to 6 of 6
I am getting this error with latex on gentoo (2.6.16-gentoo-r9). Code: #latex apoorvkhurasia.tex This is TeX, Version 3.14159 (Web2C 7.4.5) kpathsea: Running mktexfmt latex.fmt fmtutil: config file `fmtutil.cnf' not found. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624

    Latex error: I can't find the format file `latex.fmt'!


    I am getting this error with latex on gentoo (2.6.16-gentoo-r9).
    Code:
    #latex apoorvkhurasia.tex
    This is TeX, Version 3.14159 (Web2C 7.4.5)
    kpathsea: Running mktexfmt latex.fmt
    fmtutil: config file `fmtutil.cnf' not found.
    I can't find the format file `latex.fmt'!
    I re-emerged the package tetex but after one successful run the problem returned again.

    Thanks in advance.
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Hey another LaTeX user

    Anyway, sometimes the file needs to be regenerated, so:

    $ locate latex.ltx [slocate if you used the gentoo handbook]
    /usr/share/texmf/tex/latex/base/latex.ltx
    $ cd /usr/share/texmf/tex/latex/base
    $ su -
    # initex latex.ltx
    # cp latex.fmt latex.log /usr/share/texmf/web2c


    Also, LaTeX, many times, installs poorly from package management systems. Since you are on gentoo and compiling anyway, just compile the source provided from the homepage. If you are going to emerge tetex also emerge other latex packages to make sure all of the packages and styles are up to date. If you are a *shudders* KDE user, I'm not e17, then use KILE. Hell, use kile even if you aren't. It really rocks, though you have to update it to use it with xpdf and xdvi if you are not wanting to many k apps. But an emerge kile will give you all of the LaTeX packages that you will need then you can unmerge kile and the k libs. Messy I know.

    Also, if you are knew to latex, pdflatex seems to produce sloppy results sometimes. Its always better to use latex to dvi, and then a nifty app called dvipdfm to dvi-->pdf

    Cheers, and let me know if you have any more LaTeX queries. I'm not that good with it, but I really do love it

  3. #3
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624
    Error upon
    Code:
    # initex latex.ltx
    ! I can't read tex.pool; bad path?
    What do I do?
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Wow, seems to be a borked emerge of latex!

    OK, there is an incorrect option set in your texmf.cnf file, which cannot find your pool file. Check out the texmf.cnf to see that everything is setup correctly. I tried to find a good guide for this; however, frankly I couldn't.

    Is TeTex the only package you emerged?

    Try installing directly from the source provided by the latex project's homepage, as you are compiling it anyway in gentoo.

    Or try emerge pdflatex, or any tool that has latex as a dependancy.

    Post back.

  6. #5
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624

    Solved

    Found this on the net. This was indeed a broken emerge but one need not re-emerge, sometimes we can find the broken thing and carry on. Therefore did this:-
    Code:
    # mktexlsr
    # \su -
    # cd  /usr/share/texmf/tex/latex/base
    # initex latex.ltx
    That solved the problem. Thanks for all the help.
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  7. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Good job, and happy latexing ,

    I played around with some devangari and urdu font sets for tex a few weeks ago on some documents for a client, and it really does sweet!
    Operating System: GNU Emacs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •