Find the answer to your Linux question:
Results 1 to 9 of 9
I'll get right to my point. I'm looking for a bit torrent client that supports NAT traversal. In Windows, I use Bit Comet. Since there is no Linux build of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Location
    New Jersey, USA
    Posts
    94

    Bit Torrent Client with NAT Traversal


    I'll get right to my point. I'm looking for a bit torrent client that supports NAT traversal. In Windows, I use Bit Comet. Since there is no Linux build of Bit Comet, I'm looking for a client in Linux that will support many of the same functions. I've heard that Azureus supports NAT traversal but frankly I don't like Azureus. It's slow and it gives me endless amounts of error messages. I currently have Bit Tornado and Deluge Bit torrent clients installed but both programs seem significantly slower as far as download speeds go. Any suggestions would be greatly appreciated.

    For reference, I'm using Ubuntu Dapper 32-bit version.

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    I'm behing a NAT device and have used both Ktorrent (nice) and Transmission (very, very lightweight, but still a gui). No problems with either.

  3. #3
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    226
    I also use KTorrent behind a NAT. QTorrent is another graphical option that you can try.

  4. #4
    Just Joined!
    Join Date
    Sep 2003
    Location
    New Jersey, USA
    Posts
    94
    I'm assuming Ktorrent is for use with KDE. I use Gnome. Are there any others (perhaps for Gnome) that are effective in getting through?

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    BitTornado !!!





    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    According to this :
    http://en.wikipedia.org/wiki/Compari...rrent_software

    The only Linux BitTorrent Clients that supports NAT traversal are Localhost (an Azureus fork, now unmaintained), and Transmission.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  7. #7
    Just Joined!
    Join Date
    Sep 2003
    Location
    New Jersey, USA
    Posts
    94
    I've been having problems trying to build Transmission. I can build a command line version just fine but I have openSSL and GTK+ both installed on my machine. I want a nice interface.

    Code:
    System:  Linux
    OpenSSL: missing, using built-in SHA1 implementation
    GTK+:    no
    
    Now use GNU make to build Transmission.
    It may be called 'make' or 'gmake' depending on your system.
    My system reports libgtk2.0-0 is already installed as well as openSSL.

  8. #8
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by Ghost
    My system reports libgtk2.0-0 is already installed as well as openSSL.
    Yes, but that's not what you need. Transmission is asking for the development packages : libgtk2.0-dev and libssl-dev.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #9
    Just Joined!
    Join Date
    Sep 2003
    Location
    New Jersey, USA
    Posts
    94
    When I try to install the dev package, I get this error:

    Code:
    chris@cminetti:~/Transmission-0.6.1$ ag libgtk2.0-dev
    Reading package lists... Done
    Building dependency tree... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    
    Since you only requested a single operation it is extremely likely that
    the package is simply not installable and a bug report against
    that package should be filed.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.8.17-1ubuntu5) but 2.8.20-0ubuntu1 is to be installed
                     Depends: libglib2.0-dev (>= 2.8.5) but it is not going to be installed
                     Depends: libpango1.0-dev (>= 1.10.0-2) but it is not going to be installed
                     Depends: libatk1.0-dev (>= 1.6.1-2) but it is not going to be installed
    E: Broken packages
    ag is my shortcut for "sudo apt-get install"

    Does the above message mean I can't get libgtk2.0-dev through aptitude?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •