Find the answer to your Linux question:
Results 1 to 6 of 6
I'm running SUSE 10 Enterprize So I download the file amarok-1.4.4-101.guru.suse101.i686.rpm and I tryed to use the command: rpm -Uvh amarok-1.4.4-101.guru.suse101.i686.rpm to update amarok but I get the following error: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    63

    Updating Amarok to 1.4.4


    I'm running SUSE 10 Enterprize

    So I download the file amarok-1.4.4-101.guru.suse101.i686.rpm and I tryed to use the command:

    rpm -Uvh amarok-1.4.4-101.guru.suse101.i686.rpm

    to update amarok but I get the following error:

    thomas@linux-ojnv:~/Desktop> rpm -Uvh amarok-1.4.4-101.guru.suse101.i686.rpm
    warning: amarok-1.4.4-101.guru.suse101.i686.rpm: Header V3 DSA signature: NOKEY, key ID 58857177
    error: Failed dependencies:
    ruby is needed by amarok-1.4.4-101.guru.suse101.i686
    libgpod >= 0.4.0 is needed by amarok-1.4.4-101.guru.suse101.i686
    libmtp >= 0.0.12 is needed by amarok-1.4.4-101.guru.suse101.i686
    libxine1 is needed by amarok-1.4.4-101.guru.suse101.i686
    libtunepimp-mp4 is needed by amarok-1.4.4-101.guru.suse101.i686
    libtunepimp-mad is needed by amarok-1.4.4-101.guru.suse101.i686
    mad is needed by amarok-1.4.4-101.guru.suse101.i686
    libtunepimp >= 0.4.3 is needed by amarok-1.4.4-101.guru.suse101.i686
    libartsgui_idl.so.0 is needed by amarok-1.4.4-101.guru.suse101.i686
    libgpod.so.0 is needed by amarok-1.4.4-101.guru.suse101.i686
    libifp.so.4 is needed by amarok-1.4.4-101.guru.suse101.i686
    libmp4v2.so.0 is needed by amarok-1.4.4-101.guru.suse101.i686
    libmtp.so.3 is needed by amarok-1.4.4-101.guru.suse101.i686
    libmysqlclient.so.15 is needed by amarok-1.4.4-101.guru.suse101.i686
    libnjb.so.5 is needed by amarok-1.4.4-101.guru.suse101.i686
    libpq.so.4 is needed by amarok-1.4.4-101.guru.suse101.i686
    libruby.so.1.8 is needed by amarok-1.4.4-101.guru.suse101.i686
    amarok = 1.3.8 is needed by (installed) amarok-xine-1.3.8-34.2.i586

    Now I'm really hoping I don't have to install all these programs before I can update.

  2. #2
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    To the extent of my knowledge you have to install each dependency. You'd probably be better off using your distribution's package manager (I think Suse's is Yast). It'll grab/install all the dependencies for you. That's the best way to get around "dependency hell."
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Guru's repositories are all SMART channels, so if you install Smart Package Manager it will download and install the packages you need. It works a lot better than YaST, I would recommend it for anyone using SUSE.
    Check out this link on how to install it.

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    63
    I'm confused on how to use it? I installed 0.42-14 but what do I do now?

  5. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Did you install it from the link I gave or from the SUSE cds? Either way open a terminal and run
    Code:
    sudo smart --gui
    Enter your root password. If you added it from the link all of your channels should be added already so you can just search for the latest amarok in the application and load it. Alternatively you can open a terminal and run
    Code:
    sudo smart upgrade amarok
    which will do it automatically.

  6. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    63
    Thankies that makes everthing SOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO much easyer.

    But the gui won't start:

    Traceback (most recent call last):
    File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
    File "/usr/bin/smart", line 161, in main
    forcelocks=opts.ignore_locks, loglevel=opts.log_level)
    File "/usr/lib/python2.4/site-packages/smart/__init__.py", line 122, in init
    iface.object = createInterface(ifacename, ctrl, command, argv)
    File "/usr/lib/python2.4/site-packages/smart/interface.py", line 150, in createInterface
    smart = __import__("smart.interfaces."+xname)
    File "/usr/lib/python2.4/site-packages/smart/interfaces/gtk/__init__.py", line 30, in ?
    import gtk
    File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
    from _gtk import *
    RuntimeError: could not open display


    And when I tryed updating kaffeine it disappeared

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •