Find the answer to your Linux question:
Results 1 to 3 of 3

Thread: apt broken

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    apt broken

    Distro: Debian etch
    - installed basic system from net install cd then manually installed xserver, gdm, and gnome using apt

    Using the information from I tried to install drivers for my lexmark printer. the first one installed without a hitch,but the second one returned an error. Now any time i try to use apt to install or remove something i get an error message and my requested operation does not complete. makeing the .deb did not generate an error

    Install error:
    (Reading database ... 68102 files and directories currently installed.)
    Preparing to replace lexmark-z700-cups-driver 1.1.1-2 (using lexmark-z700-cups-driver_1.1.1-1_i386.deb) ...
    Unpacking replacement lexmark-z700-cups-driver ...
    /var/lib/dpkg/info/lexmark-z700-cups-driver.postrm: line 2: /etc/init.d/cups: No such file or directory
    dpkg: warning - old post-removal script returned error exit status 127
    dpkg - trying script from the new package instead ...
    /var/lib/dpkg/ line 2: /etc/init.d/cups: No such file or directorydpkg: error processing lexmark-z700-cups-driver_1.1.1-1_i386.deb (--install):
    subprocess new post-removal script returned error exit status 127
    /var/lib/dpkg/ line 2: /etc/init.d/cups: No such file or directorydpkg: error while cleaning up:
    subprocess post-removal script returned error exit status 127
    Errors were encountered while processing:

    apt error: (when trying to install anything)
    Reading package lists... Done
    Building dependency tree... Done
    E: The package lexmark-z700-cups-driver needs to be reinstalled, but I can't find an archive for it.

    P.S. did not install from source

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Have you tried doing what the error message says and tried to reinstall the driver that errored out?

    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    yes, i tried reinstalling and also remaking with alien and reinstalling

    This is the method i tried for Ubuntu and it worked fine


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts