Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Thunderbird running but not responding... How do I stop it?

    I have downloaded and installed Mozilla Thunderbird, since all my previous archived e-mails from my Windows install are in Tbird format.

    After a random number of uses, I get the error message "Thunderbird is already running, but is not responding. To open a new window, you must first close the existing Thunderbird process, or restart your system."

    Well, despite restarting my system multiple times, I still get the message. I looked up the manager with all the running systems, and Thunderbird isn't one of them.

    The only way I can get around it, is to delete all the Thunderbird files, reboot the system, and reinstall Thunderbird. Very inconvenient.

    Does anyone know what's happening here? or how to stop it?

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Riverton, UT, USA
    Sounds like the lock file isn't getting deleted when you exit the program. Look in ~/.mozilla-thunderbird/[RANDOM_NUMBER].default/ for a file called lock. (Note that [RANDOM_NUMBER] isn't the literal name of the directory, it represents a random-looking character string that's different for everybody.) If there's a file called lock, delete that and you should be all right.
    Stand up and be counted as a Linux user!

  3. #3
    Thanks! That helped me figure out what was happening. You see, I don't like to lose emails. For the last couple of years I've been using file backup software to archive all my files, including email files. When I put in my email files in a new "Local Folders" file, I deleted the -random number- file after changing the paths in Tbird, which seems to be what was causing it. I only made that link when you mentioned lock file inside the -random number- file.

    Sorted, thanks again.

  4. $spacer_open
  5. #4
    This post just appeared when I did a Google search, and I thought I'd add another solution:

    I copied my profile from my Windows machine (Application Data\etc\etc) to my Ubutnu machine. I had the same problem, and followed your steps to correct it, to no effect.

    I discovered that the problem was actually one of my Thunderbird extensions: Minimize to System Tray (MinimizeToTray ver was enabled. I uninstalled it, along with Buttons! (ver 0.5.1) and it works fine now.

    I guess I should have thought about that before - An extension designed to minimize an app. to the Windows systray probably isn't going to work in Linux *headslap*


  6. #5
    as of me using salckware, It happened with me while my machine hanged and I was in hurry so power it off and on, firefox and thunderbird didn't stat..i had to delete two files to get it work under ~/.thurderbird/[somename]/lock 0KB
    ~/.thurderbird/[somename]/.parentlock 0KB
    for firefox i just renamed the ~/.firefox and it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts