Find the answer to your Linux question:
Results 1 to 1 of 1
After installing BerkeleyDB and the necessary missing perl modules, the following erroneous output is spat onto the console: $ amavisd -c /etc/amavisd.conf Problem in Amavis::DB or Amavis::DB::SNMP code: BerkeleyDB object ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1

    Thumbs down amavisd fails to start on x86_64 arch.


    After installing BerkeleyDB and the necessary missing perl modules, the following erroneous output is spat onto the console:

    $ amavisd -c /etc/amavisd.conf
    Problem in Amavis::DB or Amavis::DB::SNMP code: BerkeleyDB object version 0.31 does not match bootstrap parameter 0.30 at /usr/lib64/perl5/5.8.6/x86_64-linux-thread-multi/DynaLoader.pm line 253.
    Compilation failed in require at (eval 37) line 14.
    BEGIN failed--compilation aborted at (eval 37) line 14.
    Undefined subroutine &BerkeleyDB::Term::close_everything called at /usr/lib/perl5/5.8.6/BerkeleyDB.pm line 1675.
    END failed--call queue aborted.

    Is it an incompatibility between 32 and 64 bit architectures and Perl/BDB? Thoughts are greatly appreciated. Thanks.
    Last edited by nikolex; 12-09-2006 at 01:00 PM. Reason: Smilies were displayed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •