Find the answer to your Linux question:
Results 1 to 4 of 4
When I try and log into my remote machine using FreeNX I get the error: Code: Server not installed or NX access disabled Error details: Code: NX> 203 NXSSH running ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392

    SSH/FreeNX problem


    When I try and log into my remote machine using FreeNX I get the error:
    Code:
    Server not installed or NX access disabled
    Error details:
    Code:
    NX> 203 NXSSH running with pid: 3214
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 10.10.10.104 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    NX> 204 Authentication failed.
    I don't understand why this is happening. The remote server seems to be running fine:
    Code:
    brandon@dimension:~$ sudo nxserver --status
    NX> 100 NXSERVER - Version 1.4.0-45-SVN OS (GPL)
    NX> 110 NX Server is running
    NX> 999 Bye
    brandon@dimension:~$
    This is my setup:
    Client = ArchLinux laptop
    Server = Ubuntu desktop

    I can ssh between the two just fine. I use a passphrase key to ssh. I haven't configured keys for FreeNX yet (I don't know how) so I think that may be the problem. Any help will be appreciated.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  2. #2
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    I think I got it working.

    I copied /var/lib/nxserver/home/.ssh/client.da_dsa.key from the Ubuntu host to /opt/NX/share/keys/server.id_dsa.key on the Arch client.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  3. #3
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Right after I got the last problem fixed I ran into another.

    Now when I go to log in, Authentication completes fine but I then get the error:
    Code:
    Session startup failed.
    Error details:
    Code:
    NX> 203 NXSSH running with pid: 2754
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: 10.10.10.104 on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    HELLO NXSERVER - Version 1.4.0-45-SVN OS (GPL)
    NX> 105 hello NXCLIENT - Version 1.4.0
    NX> 134 Accepted protocol: 1.4.0
    NX> 105 SET SHELL_MODE SHELL
    NX> 105 SET AUTH_MODE PASSWORD
    NX> 105 login
    NX> 101 User: brandon
    NX> 102 Password: 
    NX> 103 Welcome to: dimension user: brandon
    NX> 105 listsession --user="brandon" --status="suspended,running" --geometry="1024x768x16+render" --type="unix-gnome"
    NX> 127 Sessions list of user 'brandon' for reconnect:
    
    Display Type             Session ID                       Options  Depth Screen         Status      Session Name
    ------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------
    
    
    NX> 148 Server capacity: not reached for user: brandon
    NX> 105 startsession  --link="adsl" --backingstore="1" --nodelay="1" --encryption="1" --cache="8M" --images="32M" --media="0" --session="home" --type="unix-gnome" --cookie="******" --geometry="1024x768" --kbtype="pc105/us" --screeninfo="1024x768x16+render" 
    
    NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)
    NX> 700 Session id: dimension-1000-1FA770C0F62AD8C7A083518A5DBD369C
    NX> 705 Session display: 1000
    NX> 703 Session type: unix-gnome
    NX> 701 Proxy cookie: 6060cae6f9655549ee950cb2ca7628e9
    NX> 702 Proxy IP: 127.0.0.1
    NX> 706 Agent cookie: a0d770323ad41206382f2cc0bf40067b
    NX> 704 Session cache: unix-gnome
    NX> 707 SSL tunneling: 1
    NX> 504 Session startup failed.
    NX> 1004 Error: nxagent failed to start with: Unrecognized option: 1
    NX> 105 NX> 1001 Bye.
    /usr/lib/nx/nxserver: line 891:  9037 Terminated              ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )
    Killed by signal 15.
    I've been googling for the past hour and can't find a fix. Anyone any ideas?
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  4. #4
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    I just went to nomachine.com and downloaded the newest nxserver/nxnode/nxclient/nxmanager .debs and installed them on the Ubuntu desktop. Works fine now.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •