Find the answer to your Linux question:
Results 1 to 3 of 3

Thread: True-Crypt

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1


    Well I tried to install it today but I have no kernel module for it. THere isn't even an rpm for it. Help would be appreciated.
    KDE's package manager gives this answer:
    <nload/dkms-truecrypt-4.1-0.1.20060mdk.i586.rpm';echo RESULT=$?
    warning: ///home/zakaqere/Desktop/Download/dkms-truecrypt-4.1-0.1.20060mdk.i586.rpm: Header V3 DSA signature: NOKEY, key ID c9646bb4
    Creating symlink /var/lib/dkms/truecrypt/4.1/source ->
    DKMS: add Completed.
    Preparing kernel 2.6.17-7mdv for module build:
    (This is not compiling a kernel, just preparing kernel symbols)
    Storing current .config to be restored when complete
    Running Mandrakelinux style preparation routine
    make clean......
    using /proc/config.gz
    make oldconfig....(bad exit status: 2)
    running dkms_mkkerneldoth....
    Building module:
    cleaning build area....
    cd /var/lib/dkms/truecrypt/4.1/build/Linux/Kernel ; make KERNEL_PATH=/lib/modules/2.6.17-7mdv/build....(bad exit status: 2)
    Error! Bad return status for module build on kernel: 2.6.17-7mdv (i586)
    Consult the make.log in the build directory
    /var/lib/dkms/truecrypt/4.1/build/ for more information.
    Error! Could not locate truecrypt.ko.gz for module truecrypt in the DKMS tree.
    You must run a dkms build for kernel 2.6.17-7mdv (i586) first.
    FATAL: Module truecrypt not found.
    error: %post(dkms-truecrypt-4.1-0.1.20060mdk.i586) scriptlet failed, exit status 1

  2. #2
    Here's a howto I ran across recently for installing it in Ubuntu. Maybe that will help you.

  3. #3


    Nope! Unfortunately I get that same error from ld
    [root@localhost Download]# ../true*/Linux/
    Checking build requirements...
    Preparing kernel build system in /usr/src/linux-2.6.17-9mdv... /usr/bin/ld:/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.2/../../../ file format not recognized; treating as linker script
    /usr/bin/ld:/usr/lib/gcc/i586-mandriva-linux-gnu/4.1.2/../../../ parse error
    collect2: ld returned 1 exit status
    make[2]: *** [scripts/mod/modpost] Error 1
    make[1]: *** [scripts/mod] Error 2
    make: *** [scripts] Error 2

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts