Find the answer to your Linux question:
Results 1 to 4 of 4
I've got a Gateway E100M superslim laptop (it's basically the same model as the NX100X and other current "100" models -- odd Gateway naming system) with no sound from the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    No sound on Gateway E100M Laptop


    I've got a Gateway E100M superslim laptop (it's basically the same model as the NX100X and other current "100" models -- odd Gateway naming system) with no sound from the speakers. I'm running a fully updated Ubuntu 6.10.

    What I'm really looking for is someone who got sound to work on this model of Gateway laptop, but I'll take any advice I can get at this point.

    The sound card info, from the Gateway site:
    SigmaTel® 9200 Audio Chipset
    SoundBlaster® Pro, MIDI and Windows® Sound System Compatible
    3D Sound Support
    AC’97 2.3 Compliant

    The Sound Configuration app lists the default sound card as "HDA Intel" only. The Linux Device Manager lists the audio controller as: Intel 82801G (ICH7 Family) High Definition

    Sound software is installed and enabled. Rhythmbox (etc.) seems to "play" supported sound files, but no sound comes out of the speakers or headphone jack. There are no startup sounds or beeps of any kind through the speakers, though they are enabled in software. The hardware button has sound turned on (I can toggle between on and mute, and change volume, with hardware buttons, but nothing helps enable sound.) I've gone through alsa configuration; the configurator seems to identify the sound card and write the appropriate configuration files, but sound ultimately does not work. The machine is totally silent when running Linux.

    I've tried the newest Red Hat Fedora Core, Debian Etch, and Knoppix as well -- all with no luck -- so it would seem to be a systemic Linux thing. (Sound works fine in Windows XP.)

    Any insights would be appreciated.

    David

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Posts
    1

    Gateway NX100X

    If you have found a solution, could you post it here as a reply?

    I bought a Gateway NX100X and am having trouble with sound as well. I suspect that the problem could be the same.

    I've tried Fedora Core 7, Debian and OpenBSD. They all have trouble playing sound, regardless of detecting the hardware and finding a driver.

    For FC7, the snd_hda_intel kernel module didn't work.
    For OpenBSD, the azalia driver for High Definition Audio did not work either.

    Any help would be greatly appreciated!

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    No luck yet

    Sorry, I haven't figured it out yet (though, admittedly, I don't spend much time with the problem at this point). It's my only remaining issue with Ubuntu on this laptop, but it's proving intractable.

    If there's a Linux user's group somewhere within the bowels of Gateway -- someone inside who has solved this problem -- I wish s/he would speak up.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2008
    Posts
    1

    The solution

    Good news! This problem has been fixed.

    Just download and install the latest ALSA drivers. I was on 1.0.14 before, and getting 1.0.16 caused sound to work. I'm not sure about 1.0.15... maybe someone can comment on that version.

    Note: It may require a more recent kernel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •