Find the answer to your Linux question:
Results 1 to 5 of 5
I got a document in the e-mail today from an organization at school. At the bottom was a link to their Web page, which I clicked to open the page ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001

    How do you set the Web browser that OpenOffice uses?


    I got a document in the e-mail today from an organization at school. At the bottom was a link to their Web page, which I clicked to open the page in a browser. But the browser that came up was links, in a terminal! I'd prefer not to use links when in a GUI environment, but I couldn't find a way to set the default Web browser for OOo (version 2.0.4, if it matters). I ran through all the dialogs in Tools->Options, but didn't see an option for a Web browser (though there is one for a mail client). Googling didn't reveal anything either. Does anyone know how to change this setting?
    Stand up and be counted as a Linux user!

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    73
    Quote Originally Posted by Zelmo
    I got a document in the e-mail today from an organization at school. At the bottom was a link to their Web page, which I clicked to open the page in a browser. But the browser that came up was links, in a terminal! I'd prefer not to use links when in a GUI environment, but I couldn't find a way to set the default Web browser for OOo (version 2.0.4, if it matters). I ran through all the dialogs in Tools->Options, but didn't see an option for a Web browser (though there is one for a mail client). Googling didn't reveal anything either. Does anyone know how to change this setting?
    Lynx? I believe OpenOffice uses the default browser of your window manager. For KDE for example this is usually Konquerer. So to change the browser Open office users change your default browser for your desktop manager. If you are not running a desktop manager then Lynx is probably the default OpenOffice will look for.

  3. #3
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Well, shoot. I thought we were onto something there. I'm using KDE, and just now noticed that the Component Chooser in the KDE Control Center lets you pick applications for common tasks like sending e-mails and opening Web pages. Up until now I've been using the File Associations dialog to set programs for each type of file. Well, my Component Chooser didn't have a Web browser set, so I set it to Firefox. Then I checked my OOo document again, but it still opens the URL in Links. Do I need to slap it around a bit?
    Stand up and be counted as a Linux user!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    I did some looking around and it appears that it is indeed your default browser. I read somewhere that if it doesn't work after changing it in the control center, check to make sure the env variable BROWSER is set correctly.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  6. #5
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Bingo!
    Noting that I didn't have a BROWSER environment variable, I added one to /etc/environment and set it to firefox. After logging out and back in, firefox is what pops up when I click the link!

    Thanks guys.
    Stand up and be counted as a Linux user!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •