Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    error installing pango

    I want to install the GNOME 2.6 tar ball packages,while "/configure" the pango-2.6.0 for installation this is the error message:
    checking for glib -version >=2.4.0
    configure error:GLIB 2.4.0 or better is required,the latest version of
    GLIB is aviable from
    I have already installed the glib-2.4.0 and with 'locate glib-2.0.pc' this is the result 'usr/lib/pkgconfig/glib-2.0.pc' and run the ldconfig after it. plz help me.

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    New Zealand
    there is no pango 2.6 file, coz i jsut did this installation a few days ago. i think its 1.6?

    di du install glib from source or RPM?

    coz that .pc file is from an rpm isntall of glib, if u have isntalled from source there should be another .pc file in /usr/local/lib/pkgconfig/

    u can supposedly put /usr/local/lib/pkgconfig in you LD_CONFIG_PATH file but this never worked for me, i just symlinked /usr/local/lib/pkgconfig/ to /usr/lib/pkgconfig/

    once u have done that run make install again on the glib-2.4 package

  3. #3

    thanks for reply

    hi Hillmasker,
    Thanks for your help,glib-2.4.0 from tar ball was installed in /usr/
    local/lib/pkgconfig and the old version from rpm was in /usr/lib/
    pkgconfig,the symlink didn't work forme,so i remove the old version
    from /usr/lib/pkgconfig and installed it again with the prefix of './
    configure --prefix=/usr/' and then the pango-1.4.0 was successfully

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts