I have been having problems with Limewire lately. I had it up and running , then had to reinstall my java to get mozilla plugins to work properly. Now limewire won't work. I get the following error:


Starting LimeWire...
Java exec found in PATH. Verifying...
Suitable java version found [java = java full version "kaffe-1.4.2"]
Configuring environment...
Loading LimeWire:
java.lang.NoClassDefFoundError: Lorg/apache/commons/logging/Log;
at com.limegroup.gnutella.gui.GUILoader.load (GUILoader.java:49)
at java.lang.reflect.Method.invoke0 (Method.java)
at java.lang.reflect.Method.invoke (Method.java:255)
at com.limegroup.gnutella.gui.Main.main (Main.java:44)
at java.lang.reflect.Method.invoke0 (Method.java)
at java.lang.reflect.Method.invoke (Method.java:255)
at org.kaffe.jar.ExecJarName.main (ExecJarName.java:64)
at org.kaffe.jar.ExecJar.main (ExecJar.java:57)

************************************************** ****************
Something went wrong with LimeWire.
Maybe you're using the wrong version of Java?
(LimeWire is tested against and works best with with Sun's JRE, Java 1.4+)
The version of Java in your PATH is:
java full version "kaffe-1.4.2"

kaffe VM "1.1.7"

Copyright (c) 1996-2005 Kaffe.org project contributors (please see
the source code for a full list of contributors). All rights reserved.
Portions Copyright (c) 1996-2002 Transvirtual Technologies, Inc.

The Kaffe virtual machine is free software, licensed under the terms of
the GNU General Public License. Kaffe.org is a an independent, free software
community project, not directly affiliated with Transvirtual Technologies,
Inc. Kaffe is a Trademark of Transvirtual Technologies, Inc. Kaffe comes
with ABSOLUTELY NO WARRANTY.

Engine: Just-in-time v3 Version: 1.1.7 Java Version: 1.4
Heap defaults: minimum size: 5 MB, maximum size: unlimited
Stack default size: 256 KB

anyone know what to do about this ?