Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
hey, I'm trying to install xfe 0.66. [mdk9.2] After installing the required library, libfox, via rpm [1.0.47-alt1 is the version that RPMdrake says i have already installed]; i tried to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    19

    Xfe 0.66 - fails to recognize libfox lib is installed


    hey,
    I'm trying to install xfe 0.66. [mdk9.2] After installing the required library, libfox, via rpm [1.0.47-alt1 is the version that RPMdrake says i have already installed]; i tried to install xfce. During ./configure; this error msg came up:

    checking for fxfindfox in -lFOX... no
    configure: error: "libFOX not found"

    EDIT: I have figured out, via the readme, that the default path for the libs is different than that of what xfce expected for them to be.....

    [they're installed in /usr/lib
    the default ones for xfe says its supposed to be in usr/local/lib/foxrc

    - how should change the script ? I tried to copy the libfox file to the folder usr/local/lib/foxrc ; which i just created; but that did not work

    Also, I tried to do RPM of xfe first, but i had trouble with that as well with error mgs...which was:

    Some package requested cannot be installed:
    xfe-0.66-1fdr1.i386 (due to unsatisfied fox[>= 1.0])

    ================================================
    I've checked on the xfe site, along with google, and another linux forum, to no avail. If anyone could help, it's appreciated.

    first time poster,
    keyshawn

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    open : /etc/ld.so.conf

    add "/usr/lib" to the end.

    save, exit

    run "ldconfig"

    re-try your ./configure.

    Jason

  3. #3
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    i think he wants to add /usr/local/lib into /etc/ld.so.conf, as /usr/lib will probably already be there

    u coudl also type
    Code:
    ln -s /usr/local/lib/foxrc /usr/lib/

  4. #4
    Just Joined!
    Join Date
    May 2004
    Posts
    19
    thanks for the help so far, but i did that and ran ldconfig; and still received the same error message as described above.

    FYI: Here's my /etc/ld.so.conf file:

    /usr/X11R6/lib
    /usr/lib/qt3/lib
    /usr/local/lib
    /usr/lib
    /usr/local/lib/foxrc


    ================================================== =========
    thanks, keyshawn

    ps - do you think it has something to do with my libfox rpm ? should i use a different one ? [i couldnt find any other rpms for mdk besides the one i have now]
    the reason im thinking this is b/c i issued the cmd "rpm -q libfox" in the CLI, but it said Libfox wasn't installed....but when I went to rpmdrake [the gui] it said that I had libfox installed.

  5. #5
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    change the last line to just /usr/local/lib

  6. #6
    Just Joined!
    Join Date
    May 2004
    Posts
    19
    Quote Originally Posted by Hellmasker
    change the last line to just /usr/local/lib
    i followed your instructions and I'm still gettiing the same error msg.

    thanks for your effort,
    keyshawn

  7. #7
    Just Joined!
    Join Date
    May 2004
    Posts
    19
    Does anyone else have any advice ?

    Thanks,
    keyshawn

  8. #8
    Just Joined!
    Join Date
    Jun 2004
    Location
    France
    Posts
    2
    This is because the libFOX library was renamed form libFOX to libFOX-1.2.
    You can apply the following patch to make the configure file aware of this modification:
    Code:
    diff -Nur xfe-0.66/configure xfe-0.66-new/configure
    --- xfe-0.66/configure  2004-01-28 17:10:32.000000000 +0100
    +++ xfe-0.66-new/configure      2004-06-04 19:24:38.000000000 +0200
    @@ -7932,7 +7932,7 @@
       echo $ECHO_N "(cached) $ECHO_C" >&6
     else
       ac_check_lib_save_LIBS=$LIBS
    -LIBS="-lFOX  $LIBS"
    +LIBS="-lFOX-1.2  $LIBS"
     cat >conftest.$ac_ext <<_ACEOF
     #line $LINENO "configure"
     /* confdefs.h.  */
    @@ -7985,7 +7985,7 @@
     #define HAVE_LIBFOX 1
     _ACEOF
     
    -  LIBS="-lFOX $LIBS"
    +  LIBS="-lFOX-1.2 $LIBS"
     
     else
       &#123; &#123; echo "$as_me&#58;$LINENO&#58; error&#58; \"libFOX not found\"" >&5
    Same thing for headers which have been renamed from /usr/include/fox to /usr/include/fox-1.2.
    The workaroud is to create a "symlink /usr/include/fox => /usr/include/fox-1.2".

    Then, you _only_ need to port the code itself from fox 1.0 to 1.2. Good luck

  9. #9
    Just Joined!
    Join Date
    May 2004
    Posts
    19
    ummm...what directory do i run this code this in; what file do i edit to edit the code ?!??! [im sorta a noob, so im confused what you typed in, orelien.

  10. #10
    Just Joined!
    Join Date
    Dec 2004
    Posts
    1
    Hello!
    This is from the Xfe home page:

    "If you have an RPM based Linux system, you only need the fox package to run Xfe and optionally the fox-devel package to compile it".

    Maybe you lack the fox-devel package?

    Cheers!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •