Find the answer to your Linux question:
Results 1 to 3 of 3
I've been trying to figure out a problem associated with QT-4 running on FC6 and an application written to QT-3 looking for Type1/TrueType system fonts. Unfortunately, the application, lignumCAD, has ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    QT Guru anyone?


    I've been trying to figure out a problem associated with QT-4 running on FC6 and an application written to QT-3 looking for Type1/TrueType system fonts. Unfortunately, the application, lignumCAD, has not been maintained since 2002 and both the developer and his company appear to have fallen off the face of the planet. (http://lignumcad.sourceforge.net/doc/en/HTML/index.html)

    So, not being a Qt expert, I've managed to port the lignumCAD code to FC6 - but still dependent on QT-3 libs. And, guess what, I can now successfully and with frustrating regularity recreate the original problem from the RPM install. The application dies after not finding system TrueType/Type1 fonts via Qfont::rawName().

    • I have run /usr/lib/qt-3.3/bin/qtconfig and set the default font to Arial/12pt - which saves to ~/.qt/qtrc. No joy.
    • I have run /usr/lib/qt4/bin/qtconfig-qt4 and set the same defaults - which saves to ~/.config/Trolltech.conf. No joy.
    • I have tried umpteen (<-- technical term for 'lots') different Type1 and TrueType fonts that are in deed loaded on my system. No joy.
    • I have mucked with Xresources and any other system font-like configuration I can find. Again, no joy.


    I'd hoped that after some time porting/updating lignumCAD so that it would compile/run on FC6 that I would be able to debug the problem during runtime. Again, being Qt stupid, no joy.

    I know that there is a compassionate QT Guru lurking out there who could answer this with only a moment of thought. This frustrated old school hacker would be most appreciative. I'd offer my firstborn, but I'm sure you wouldn't want to pay for his college...

    Fred

  2. #2
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1
    Hi,
    I am interested in using lignumCAD. I know what to do to remove this font problem. But i have to have working souce code. I try compiling lignumCAD on Gentoo from sources and this failed because a lot of errors

    In the main program is some font check, but this is not needed.
    If someone can recompile lignumCAD without that pice of code would be nice

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2
    Seweryn,
    I'll be happy to send you the FC6 based ported code. It compiles for me, but since that time have migrated to F8 and experienced h/w failures preventing me from this and other pursuits. Once back up, will be happy to share.
    I should point out that I attempted to find work arounds for the section of code you mention, but none of them worked. The specific font code was maintained for back support in Qt4, so tried the Qt4 updates with no success. Going from memory since I can't look at the code directly right now.
    Take care,
    Fred

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •