Find the answer to your Linux question:
Results 1 to 2 of 2
In openSuse 10 (with Apache 2 + MySQL + php5) I have installed jre1.5.0_11 So I have the following directory tree /usr/lib/java /usr/lib/java/jre1.5.0_11 I have defined in /etc/profile JAVA_HOME=/usr/lib/java (and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! dianelane's Avatar
    Join Date
    Jul 2006
    Posts
    6

    Set up java (and jre)


    In openSuse 10 (with Apache 2 + MySQL + php5) I have installed
    jre1.5.0_11

    So I have the following directory tree
    /usr/lib/java
    /usr/lib/java/jre1.5.0_11

    I have defined in /etc/profile
    JAVA_HOME=/usr/lib/java (and also tried .../jre1.5.0_11)
    export JAVA_HOME

    If I browse /localhost:8080/ I get an error: page not found

    In addition I have also a
    /usr/lib/tomcat

    mod_jk-ap20 was installed, but now I have removed it, to try
    apache2_prefork is now installed

    Could you help me? Thank you.

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    The first step is to get Apache up and serving. That's not such a trivial thing that it can be described in a message like this, but I'll mention a few things.

    You have to edit the main configuration file, which is probably /etc/httpd/conf/httpd.conf. One of the things in that file is a line like the following. This is the directory where index.html (or index.php, etc.) must be.
    DocumentRoot "/var/www/html"

    Once that's all set up, the server must be started:
    /etd/init.d/httpd start

    Verify it's setup to startup on reboot:
    chkconfig --list httpd

    If you see 5:off, then enable it with:
    chkconfig --add httpd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •