Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I am installing an AGP card on SuSE 9.0. The card did not come with any support. I am using YAST to load the drivers, but I keep getting an ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    48

    Installing nvidia driver


    I am installing an AGP card on SuSE 9.0. The card did not come with any support. I am using YAST to load the drivers, but I keep getting an error message "patch pathway not found". When I download the driver from the nvidea how -to, it went to a file on the desktop. Where is it supposed to go and how do I create a path for it? I am a Windows convert and I am not familliar with the command line yet.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    If you want to install the driver, (i assume it's a .pkg.run file).

    Press ctrl + alt + F1, this will take you to a command line.

    Log in as root

    type
    Code:
    init 3
    you NEED to do this to install the driver, as you cannot install it with the X-server running.

    Code:
    cd /path/to/folder/where/file/is/stored
    
    sh <filename>
    (Just try typing the first few characters and press tab)

    follow the on screen prompts.

    when it comes back to the command prompt, type
    Code:
    sax2 -m 0=nvidia
    (note: 0=nvidia is the number 0 not letter O)

    then again follow the sax2 prompts.

    When back to the command line type

    Code:
    init 5
    Now you are logging in with the new nvidia driver installed, you should find that an NVidia splash screen comes up at some point.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    48

    nvidia driver

    I tried installing the driver, but I get an error message that I don't have the interface for this kernel installed not can one be located in nvidia website. What do I do now?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2004
    Location
    Northwestern New Jersey
    Posts
    72
    it should just say it will attempt to compile its own interface and work out. Did it give you the option to just have it create one itself? If that doesn't work, you can try making a symlink to your linux source directory.

  6. #5
    Just Joined!
    Join Date
    May 2004
    Posts
    48
    I am getting the message "No precompiled kernel interface" After looking on the Nvidia web site and checking the files I get the message "unable to find kernel source tree". I looked on the download from Nvidia and the source file listed is http://download.nvidia.com/xfree86/L...-5336-pkg1.run
    How do I get the source files to interface with the kernel? What is the next step?

  7. #6
    Linux Newbie
    Join Date
    Feb 2004
    Posts
    139
    On my install I got the same problem, however I had the kernel-source in here already, and it automatically selected the kernel-sources and compiled the module without me having to do anything.
    If you love something, emerge it

  8. #7
    Just Joined!
    Join Date
    Jun 2004
    Posts
    33
    dshock512 that happened to me. For some reason when I used yast to install the drivers I get that error. I had to reformat then install the drivers manually.

  9. #8
    Just Joined!
    Join Date
    May 2004
    Location
    Northwestern New Jersey
    Posts
    72
    hmm do you have /usr/src/linux created? One time I had problems with it and that happened to make it work because i don't think it knows where else to look so make sure that is there (as a symlink to your actual kernel directory) if not just post again.

  10. #9
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    when i had this problem i installed and updated the kernel-source package through yast, and then tried again, as described by me earlier, and now it works perfectly.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  11. #10
    Just Joined!
    Join Date
    Jun 2004
    Posts
    11
    i had the same problem even after i installed the kernel sources, so in yast I just selected all of the kernel development packages and then it worked so it must need something in addition to the kernel source package

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •