You won't be able to use Yahoo messenger in such an old and unsupported version of Linux, protocols change and the messenger included with SuSE 9.3 no longer works. Get current!!