Find the answer to your Linux question:
Results 1 to 4 of 4
sorry if I'm posting this in the wrong spot, I'm new to actually posting something) How I got where I am: In hopes to get beryl running, I attempted to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    yet another Xserver Failed to load default font 'fixed' thread (nothing seems to fix)


    sorry if I'm posting this in the wrong spot, I'm new to actually posting something)

    How I got where I am:
    In hopes to get beryl running, I attempted to upgrade xorg to 7.0 (following the beryl wiki for slackware) When I went to run xserver and had a HUGE list of version conflicts. Got aggravated with it so I decided to re-install without ANY Xserver packages


    over a few days I installed the latest (stable) versions of the following
    expat
    gperf
    zlib
    libdrm
    freetype
    fontconfig
    libxcb
    gperf
    fontconfig


    installed ALL most recent versions of protos given by xorg
    installed ALL most recent libs given by xorg
    installed Xserver 7.2
    installed ALL most recent utils given by xorg
    installed mkfontdir
    installed mkfontscale
    installed ALL most recent fonts given by xorg

    set IPV6 module to load in rc.d

    I ran xorgconfig which gave me error about xkb rules missing, I reinstalled all xkb packages in hopes to fix it, but no fix. I ended up copying the "rules" folder from a system that works and it made it through with only minor error) intending to deal with it later)

    installed NVIDIA driver (v1.9755)

    FINALLY, I get to run xserver but wait

    when I go to run xserver, I get the NVIDIA logo on the screen, then it stops with
    "Fatal server error:
    could not open default font 'fixed'"

    I checked the FontPaths to make sure they were correct, I checked the fonts.alias file inside of the /fonts/misc folder to make sure "fixed" was declared...it is.

    after reading up on it, I found a few things with xfs and fontconfig

    fc-cache runs successfully
    fc-cat gives me a bunch of random information
    fc-list gives me a list of fonts. this list doesn't contain 'fixed' BUT, from what I read, Xserver runs it's own font server, and if I'm not mistaken, should not be dependent on font config


    I think perhaps it has something to do with xfs but then everything I read says xfs does not need to be running for xserver to use fonts (is that really true?)

    as a last hope, I took one of the names of the fonts which font config (fc-list) finds
    and ran
    X -fn Courier:style=Bold
    which then returned same fatal error except the default font name it couldn't load was 'Courier:style=Bold'

    also tried X -fn Courier again - not able to load 'Courier'


    can see my log file here
    http://cs.selu.edu/~mwichers/Files/Xorg.0.log

    my config file here
    http://cs.selu.edu/~mwichers/Files/xorg.conf

    and the font.alias file located in /usr/local/lib/X11/fonts/misc

    http://cs.selu.edu/~mwichers/Files/fonts.alias



    I'm really at a complete loss usually a few to many google searches and I get my problem solved, but every google search is leading me to the same useless "fixes" apt-get (BAH!) invalid font directory and fc-cache(HUH?! (no..running that did not work))


    thank you much in advance and if someone actually guides me into a better direction than I'm going in THANK YOU especially)

    P.S. sorry for being wordy, I just realize that the more details I can give, the better and never realize how much it too much

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    90
    No flames please
    but just a basic thing:
    /etc/init.d/xfs start
    is xfs running
    check if it shows as process in ps -fe
    and may be everytime you start it is dying ?
    Most of the times i have troubleshooted this was the case
    where xfs is not started and sometimes even if xfs is started, it dies immediately after stating (which case, log is found at /var/log )

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4
    sweet...that is a HUGE hint xfs is NOT running

    that command gives me "-bash /etc/init.d/xfs: No such file or directory
    actually seeing I have no init.d file or directory period..xept in xorg source (probably need to read into that for slackware)

    just plain 'xfs start' returns
    "usage: xfs [-config config_file] [-port tcp_port] [-droppriv] [-daemon] [-nodaemon] [-user user_name] [-ls listen_socket]

    do a locate xfs I DO get a result "/usr/local/bin/xfs" (get a whole bunch of other results, but that's the only PLAIN xfs result)

    OK THEN! so I take it xfs is supposed to be running already before I go to start x...So i guess i need to figure out whats up with xfs


    any reccomendations would be much appreciated, but if not, a few hours of google and trial and error will probably lead me to something

    again...thank you much

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4
    got xfs running (not sure if it's running right createda config file...ran

    xfs -config /usr/X11/lib/X11/fs/config -port 7100

    now xserver will load font path unix:/7100 it does not return any error on that font path, but still tells me could not load default font 'fixed' only NOW, it jumps to that error much quicker I stop xfs and it gives me error

    Could not init font path element unix/:7100, removing from list!

    So this leaves me to assume that xfs IS running properly at this point however I still have a concern over the fact that "xfs start" is not a command....


    xfs config file


    # font server configuration file

    # allow a max of 10 clients to connect to this font server
    client-limit = 10

    # when a font server reaches its client limit, start up a new one
    clone-self = on

    # use the UNIX syslog utility to log errors.
    use-syslog = on

    # list of font directories
    catalogue = /usr/local/lib/X11/fonts/misc/,
    /usr/local/lib/X11/fonts/Speedo/,
    /usr/local/lib/X11/fonts/Type1/,
    /usr/local/lib/X11/fonts/75dpi/,
    /usr/local/lib/X11/fonts/100dpi/



    # file used to log errors if syslog is not used.
    error-file = /var/llog/fs-errors

    # 12 point in decipoints
    default-point-size = 120

    # 100 x 100 and 75 x 75
    default-resolutions = 75,75,100,100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •