Find the answer to your Linux question:
Results 1 to 8 of 8
system-config-display won't allow monitor list-tree to expand. Therefore I can't make monitor selection. Thus I'm locked into 800x600. Any help would be great. Thanks. cole o xorg-x11-server-Xorg-1.1.1-47.7.fc6 o Linux Linux.chome ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    4

    system-config-display: no monitor choice


    system-config-display won't allow monitor list-tree to expand. Therefore I can't make monitor selection. Thus I'm locked into 800x600. Any help would be great. Thanks.

    cole

    o xorg-x11-server-Xorg-1.1.1-47.7.fc6
    o Linux Linux.chome 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 athlon
    i386 GNU/Linux
    o VGA compatible controller: Trident Microsystems CyberBlade/XP (rev 63)
    o HP Pavilion N5425 Laptop

  2. #2
    Linux User glennzo's Avatar
    Join Date
    Sep 2004
    Location
    Salem, Mass
    Posts
    464
    Quote Originally Posted by cragland
    system-config-display won't allow monitor list-tree to expand. Therefore I can't make monitor selection. Thus I'm locked into 800x600. Any help would be great. Thanks.

    cole

    o xorg-x11-server-Xorg-1.1.1-47.7.fc6
    o Linux Linux.chome 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:37:32 EDT 2006 i686 athlon
    i386 GNU/Linux
    o VGA compatible controller: Trident Microsystems CyberBlade/XP (rev 63)
    o HP Pavilion N5425 Laptop
    I don't think it's too important what you call the monitor. What IS important is selecting the correct modes and adding the correct horizontal and vertical rates for your monitor. Backup /etc/X11/xorg.cong and then edit it manually. Look for this section
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    and add the resolutions you want to use. Then look for this section
    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 28-51
    VertRefresh 43-60
    EndSection
    and make sure the numbers reflect the ones for your monitor. You can also try using a generic driver
    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
    Driver "nv" <-- Generic NVidia Driver
    BusID "PCI:1:0:0"
    EndSection
    just to get a screen and a working xorg.conf. Then you can work from there to improve things.
    Glenn
    Powered by Fedora

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by cragland
    system-config-display won't allow monitor list-tree to expand. Therefore I can't make monitor selection. Thus I'm locked into 800x600. Any help would be great. Thanks.
    Select 'Generic' Monitor in the List.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined!
    Join Date
    Apr 2007
    Posts
    4

    Reply -- xorg.conf; xorg.0.log; xorg.conf.backup attached

    Thanks for your response. I did try hacking xorg.conf with higher resolutions. I've attached the log file which states that its throwing out 1024x768. It then goes on to use 800x600 and 640x480. Thanks.

    cole

    Quote Originally Posted by glennzo
    I don't think it's too important what you call the monitor. What IS important is selecting the correct modes and adding the correct horizontal and vertical rates for your monitor. Backup /etc/X11/xorg.cong and then edit it manually. Look for this section
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "640x480"
    EndSubSection
    and add the resolutions you want to use. Then look for this section
    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 28-51
    VertRefresh 43-60
    EndSection
    and make sure the numbers reflect the ones for your monitor. You can also try using a generic driver
    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
    Driver "nv" <-- Generic NVidia Driver
    BusID "PCI:1:0:0"
    EndSection
    just to get a screen and a working xorg.conf. Then you can work from there to improve things.
    Attached Files Attached Files

  5. #5
    Just Joined!
    Join Date
    Apr 2007
    Posts
    4
    Can't even select that. That's the problem, even the CDT and LCD generic won't expand -- the 'OK' button remains unbolded. Thanks.

    cole

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    edit xorg.conf file manually and set driver to "vesa". this will fix graphics temporarily.
    or nvidia drivers.
    Code:
    yum -y install kmod-nvidia
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Apr 2007
    Posts
    4

    Thanks

    Thanks for the vesa solution. You said to would due temporarily. What should I do to make it permanent? Do I need the navida driver if my chipset is cyberblade and driver trident? thanks again.

    cole

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    generic "vesa" driver doesn't support 3D effects. it works fine otherwise.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •