Find the answer to your Linux question:
Results 1 to 1 of 1
Hi All I am currently working on a development project for HP, where we have to integrate WACOM GRAPHIRE 4 module to a CM-X270 board running Linux 2.6.16 Kernel, as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    1

    X not accepting WACOM input


    Hi All
    I am currently working on a development project for HP, where we have to integrate WACOM GRAPHIRE 4 module to a CM-X270 board running Linux 2.6.16 Kernel, as one of our deliverable. I built the wacom as Kernel Module rather than as a separate drive. (Make Menuconfig * for WACOM )
    The Wacom Driver is up which I verified through messages from
    "$:more /proc/bus/usb/devices" . Message there says driver=wacom for my wacom device.

    Moreover I can see the data dump in file /dev/input/event2.

    Now the X is not recognizing my device. It is not giving any response for movement of my wacom pen .

    I am manually writing to XF86Config-4 file, located at "/etc/X11/XF86Config-4"

    All configurations are same as that mentioned in Linux wacom project.

    http://linuxwacom.sourceforge.net/in...howto/inputdev

    I have also attached a copy of my XF86Config - 4 files. May be it will help you to correct me my mistakes.

    My EXPERIMENTS :
    ------------------
    First I would like to admit that I am a newbie to this Linux.

    The X window system is implemented as frame buffer in my system.

    Now at present I am trying to find out the relationship b/w XF86Config - 4 file and mouse. (Since Wacom would be complicated to understand)

    There were 2 mouses mentioned in XF86Config file namely GenericMouse and ConfiguredMouse.
    I removed both of them from the serverlayout and restarted X. Even then mouse seems to be working.

    Then I moved the XF86Config file to the /tmp directory and again restarted X - shocking even then the X Window was up and mouse was responding.

    Now I doubt the control of XF86Config - 4 file over X window. I did not build/compile the X window on my board, It was separately provided to us by "Compulab" manufacturers of cm-x270 board. I found that it was integrated with the file system.

    There is only file relating to the configuration of X (XF86Config-4).

    Moreover I cannot find XFree86.0.log file which is usually present in in /var/log folder.

    Later I tried using the dpkg command to configure 'X', I found a document and it me to follow following procedure.

    1) Generate a copy of XF86Config file. ( Just as a backup may be )
    2) md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
    but I cannot locate directory called xfree86 in /var/lib, and the machine gave me the same error as response.
    I tried to locate .dm5sum files : locate *.md5
    and : find / -name *.md5
    Both search did not yield me anything.

    3) dpkg-reconfigure xserver-xfree86 (I doubt it has to be given as XF86Config-4 for my system, but any way it doesn't matter presently)
    But the following error report was displayed.
    debconfbDriver "Config" : could not open /var/cache/debconf/config.dat

    I tried to see the properties of the folder in /var/cache by running ls -l there.

    It said me the folders debconf and apt folders are symbolic links,

    debconf -> /mnt/net/var/cache/debconf
    apt -> /mnt/net/var/cache/apt

    I am unabe to move forward / make out as to why Wacom is not responding.
    Please Help

    Thanks in advance
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •