Hi everyone:

Am trying to clone a Windows 2000 SP4 machine so that I don't have to install from scratch and download the 1 zillion updates that it needs. I've been using Rdrive Image v4.0 without any major issues, but on the last two computers I need to set up, the program will not restore the image, because it says that the partition table on the target drive is full. I've tried swapping hard disks, I've tried restoring different images, I've tried just about everything, and get that dumb error every time.

Soooooooooooooo ... last night, I finally gave up on Rdrive, and turned my attention to ImagePart. It took me awhile to figure it out, but I think I got it. However, the results were not exactly desirable. When I try to boot the computer, I get a blinking cursor in the upper left-hand portion of the screen, and it does nothing else.

I'm wondering if you could help me by looking at the steps I'm taking to do the image, and to do the restore. Perhaps there's something I'm missing. One of the things I'm not sure about is the option that says to restore the MBR off the image. I tried that, but the program said that it could read sector 0, and that the MBR couldn't be copied.

Here's what I did:

Computer setup:
Primary Master - hda (hard disk I want to send the image to)
Secondary Master - none
Primary Slave - cdrom
Secondary Slave - hdd2 (hard disk partition that has the image on it)


1. Used my Linux sysrescd and booted through.

2. The first thing I did was to go into Gpartd and set up an NTFS partition on hda. I'm not sure if I did this right. I set up the partition to be the entire hard disk. Should I instead set it to the same size as hdd2 (8.8gb)? Can I go back later and adjust the partition size?

3. After I've done that, I make sure that the new partition I created on hda is not mounted (umount /dev/hda1)

4. Then, I use the ntfs-3g thingy to get access to the partition where I want to save/load the image from:
ntfs-3g /dev/hdd2 /mnt/windows

5. Then, I go into X-windows, and start up partimage. I want to image hdd1,because that's where the Win2k setup is. So, I image that with no problems, and the file are created on hdd2.

6. Now, I want to restore hda1 using the image stored on hdd2. I restore the image from /mnt/windows/imagename.000, and the image restores successfully.

7. When I try to boot, I get the blinking cursor in the upper left part of the screen.

---------

I have this feeling that I'm not getting the MBR copied, and that's why I'm having the problem. When I try to restore the MBR from the image file, it says that it can't read sector 0 and I can't continue. Is there another way to write a Win2k MBR to the disk to make it boot? I did verify that the "boot" flag is on in Gpartd.

So as you can see, I'm probably nuts and am way off, so if anyone would be so kind as to help me, I would be eternally grateful!

MANY thanks!
-Michael