Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    ? on Squid Cache Server

    I recently installed Squid on my Linux box but having one problem. at bootup the squid server is not starting and I have to manually start it from the console. I have only a dialup line hooked to my computer. A look in the log files yields this:
    Jun 8 09:50:11 localhost squid[1652]: Squid Parent: child process 1746 started
    Jun 8 09:50:11 localhost (squid): Could not find any nameservers. Please check your /etc/resolv.conf file or use the 'dns_nameservers' option in squid.conf.
    Jun 8 09:50:11 localhost squid[1652]: Squid Parent: child process 1746 exited due to signal 6
    Jun 8 09:50:11 localhost squid[1652]: Exiting due to repeated, frequent failures
    obviously squid is not going to find any dns servers on startup w/dialup setup. Is there something in squid.conf I should be setting to avoid this problem? Any suggestions.

    p.s. i have no resolv.conf file and am using DHCP on my ppp connection...

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    London, UK
    Call up your ISP, ask them for the IP Address of their Primary and Secondary DNS servers.

    create the file /etc/resolv.conf.

    In it, write:

    Replace the sample 194.x.x.x numbers above with the numbers given to you by your ISP.
    the 194.x.x.x numbers in my sample will not work for you unless you have the same ISP as me, you DO need to phone your ISP to obtain the correct Primary and secondary DNS server addresses

    That should do the trick.


  3. #3
    thanx for the info. the only thing is i'm using is dhcp. why doesnt squid know this and not get itself in a bunch on bootup. I looked in resolv.conf once i was logged in and saw kppp daemon had put tempory entries for my dns in the this file. Now i have duplicate entries when i'm logged in. do u know of any way around this trouble. i tried using bogus dns entries on startup and squid was starting fine on bootup but when goto 2 use mozilla i get a time out on lookup.I guess because the bogus entries are first in the list squid doesnt just keep checking all dns servers in resolv.conf. I'd be interested to hear if u have any thoughts?



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts