Find the answer to your Linux question:
Results 1 to 2 of 2
Upon trying to install Ecasound on Mandriva, I received the error that there was no acceptable C compiler found in $path. After some intense googling, I found an rpm for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    22

    Ecasound and Gcc help


    Upon trying to install Ecasound on Mandriva, I received the error that there was no acceptable C compiler found in $path. After some intense googling, I found an rpm for GCC at Pre-compiled and source RPM packages (analog, binutils, gcc). I downloaded the rpm at the bottom called gcc-3.3.3-1.src.rpm that was labled as the 'Source Package', did an rpm -i on it and it went straight to the next line with no issues. Assuming it was installed, I went back and tried to get Ecasound working, and received the same error. Did GCC not get installed correctly? Did it not get installed to that $path thing or whatever? Any help would be greatly appreciated.

  2. #2
    Linux Engineer Thrillhouse's Avatar
    Join Date
    Jun 2006
    Location
    Arlington, VA, USA
    Posts
    1,377
    Mandriva's package manager is called urpmi. You should use it to install software whenever possible (which should be more often than not). You can learn how to use it here.

    You can see if gcc is installed by running:
    Code:
    gcc --version
    If you get output that gives you information about the copyright and version of gcc, then it is installed and it is in your $PATH. If you get something that says "command not found" then it either isn't installed or isn't in your $PATH. Your $PATH variable tells the system what directories to search in order to find a command or program. You can find out what your path is by running:
    Code:
    echo $PATH
    In your case, the system is telling you that it couldn't find gcc in any of the directories listed in the output of the above command. Therefore, it either isn't installed or it is installed and it just isn't found in any of the directories listed in the output of the above command. If you use urpmi to install software, that software will most certainly be in your $PATH by default.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •