Find the answer to your Linux question:
Results 1 to 3 of 3
I've been using Apollon for a few months now with no problems. One day all of a sudden it just wont connect anymore. I tried configuring the gift-setup, re-installing Apollon. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2004
    Location
    California
    Posts
    7

    giFT daemon Connection Error


    I've been using Apollon for a few months now with no problems. One day all of a sudden it just wont connect anymore. I tried configuring the gift-setup, re-installing Apollon. Finally I uninstalled Apollon completley. I installed apollon-dist-0.3.run the all in one package. It still wont connect, I get this in the info window:
    -------------------------------------------------------------------------------------------------------------
    The giFT daemon, which is responsible for connecting to the various networks, appears to be down and I don't seem to able to start it.
    Probably your giFT installation is corrupted. Try starting giFT manually by typing "giftd" on the command line. If this gives errors, there's likely some internal error in giFT or in your giFT configuration. Refer to the giFT homepage at http://giftproject.org for help.
    -------------------------------------------------------------------------------------------------------------
    I tried that and that doesn't work...any suggestions?

  2. #2
    don
    don is offline
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    101
    Apollon is the front end to giFT file sharing daemon. as mentioned try running giftd from a console and see if it runs corrects. upon any errors just check if giFT is configured correctly in its config file
    I\'m just a simple fisherman blessed with a lot of friends

  3. #3
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    In my experience with Apollon it seems that sometimes when you install the FastTrack plugin, it doesnt reside where the programs thinks it does. I dont recall the exact directory it should be in, but what you may need to do i search for the *.so that corresponds to fasttrack, i believe it is libfasttrack.so You can run slocate if you installed more than a day ago to find it, or search usr/lib and /usr/share/lib i believe in one of them there will be giFT folder where there should be libfasttrack.so make sure that both have it and try to reconnect. Also if you are using any other plugins like Gnutella make sure their .so files are there along with their .la (for example libfasttrack.la and libgnutella.la) Once they are there try to reconnect. If it still doesnt work, go to Setting/Configure APollon/Advanced and manually add the plugin by browsing for the .so where ever you put it in the new directory.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •