Find the answer to your Linux question:
Results 1 to 6 of 6
I recently decided to try out a desktop system monitor. I thought that I should start with TyopoytaORvelo System MOnitor (Torsmo). After I was told that it was unmaintained, it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! nachos's Avatar
    Join Date
    Jul 2006
    Posts
    29

    trouble working with Conky


    I recently decided to try out a desktop system monitor. I thought that I should start with TyopoytaORvelo System MOnitor (Torsmo). After I was told that it was unmaintained, it was suggested that I move to Conky. I run Sabayon, so I used portage to get the application, and It works great; save one problem. I don't know how to configure it. I found where the files were located (/usr/share/doc/conky-1.4.5/) and I was given the option to extract, I extracted to my home folder (/home/<user>). I could then preceed to edit the file, except nothing took. I honestly am lost as to what to do, I have spent the past five hours researching, they might be speaking english, but its all greek (or geek. OY!) to me.

    Please help.

    I also apologize for the bad, bad pun. I am shame faced.

  2. #2
    Linux Newbie rudie_rage's Avatar
    Join Date
    Jun 2007
    Location
    Canada
    Posts
    133
    No worries.

    Conky reads the config file usually from ~/.conkyrc

    all you have to do is make that file the way you want it. Dont know how? Im sure man conky will tell you. Are you like me and are too lazy to start from scratch? google .conkyrc and steal someone elses, then modify it.

    Its really pretty straightforward. The most complicated part is knowing what network device you connect to so conky can tell you how much bandwidth your using. The second most complicated part is knowing hex colour codes to make it look perdy :P
    Living the digital dream....
    Disclaimer: I may be wrong since I was once before.
    Breathe out so I can breathe you in ~~Everlong

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Yep, everything you need to know to configure it is on the conky website:

    conky

    Conky Variables

    ~/.conkyrc settings

    Conky is all manually configured, so it will take a while to get it the way you want.
    oz

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! nachos's Avatar
    Join Date
    Jul 2006
    Posts
    29
    Okay, still having problems. I thought that perhaps I misnamed the file. whenever I typed $gedit ~/.conkyrc I got nothing. However, when I left the period out, I got the file. I tried to rename the file with the period, It disappeared. Perhaps I am just not experienced enough to use this yet, because I have read, re-read, and struggled with this for hours on end. I know that something should have worked, because I copy-pasted someone else's conky code into the file.

    I am gonna go punch a mattress right now.
    Please help if you can. Thanks.

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    The period means that it's a hidden file. You can set gEdit to see hidden files, though. Look in the menu in gEdit.
    oz

  7. #6
    Just Joined! nachos's Avatar
    Join Date
    Jul 2006
    Posts
    29
    Aha, that did it.
    though i need a new matress now.

    oops

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •