Find the answer to your Linux question:
Results 1 to 7 of 7
I've installed arch linux, the flaw i'm encountering my hard disk is IDE type but it names it as "sda" instead of "hda". Is it a bug in arch linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105

    Wrong hardisk mapping.....


    I've installed arch linux, the flaw i'm encountering my hard disk is IDE type but it names it as "sda" instead of "hda". Is it a bug in arch linux or is it the how it maps hardisk.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    No, that's normal in Arch starting with the release of the 2.6.20 kernel.
    oz

  3. #3
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105
    ozar now the problem i encounter is filesystem check failed. I'll get u all the possible information regarding it.

    Code:
    $df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/sda8              27G  565M   25G   3% /
    none                  252M     0  252M   0% /dev/shm
    Code:
    $fdisk -l /dev/hda
    Disk /dev/hda: 80.0 GB, 80060424192 bytes
    255 heads, 63 sectors/track, 9733 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x340b340a
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1               1        1275    10241406    7  HPFS/NTFS
    /dev/hda2   *        1276        1300      200812+  83  Linux
    /dev/hda3            1301        9733    67738072+   f  W95 Ext'd (LBA)
    /dev/hda5            1301        2575    10241406    7  HPFS/NTFS
    /dev/hda6            2576        3791     9767488+  83  Linux
    /dev/hda7            3792        6223    19535008+  83  Linux
    /dev/hda8            6224        9733    28194043+  83  Linux
    Code:
    $cat /etc/fstab
    
    #
    # /etc/fstab: static file system information
    #
    # <file system>        <dir>         <type>    <options>          <dump> <pass>
    none                   /dev/pts      devpts    defaults            0      0
    none                   /dev/shm      tmpfs     defaults            0      0
    
    
    /dev/cdrom /mnt/cdrom   iso9660   ro,user,noauto,unhide   0      0
    /dev/cdrom1 /mnt/cdrom1   iso9660   ro,user,noauto,unhide   0      0
    /dev/dvd /mnt/dvd   udf   ro,user,noauto,unhide   0      0
    /dev/fd0 /mnt/fd0   vfat   user,noauto   0      0
    /dev/sda8 / ext3 defaults 0 1
    Now the error which i'm during boot is,
    Code:
    Checking Filesystems
    
    /dev/sda8:
    
    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is calid and it really contains an ext2
    filesystem ( and not swap or ufs or something else ) then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock.
    	e2fsck -b 8193 <device>
    
    ****************FileSystem Check Failed*****************
    
    Please repair manually and reboot. Note that the root
    filesystem is currently mounted read-only. to remount
    it read-write type: mount -n -o remount,rw /
    when you exit the maintenance shell the system will 
    reboot automatically.
    
    *************************************************************
    then i altered the /etc/fstab,
    Code:
    $cat /etc/fstab
    
    #
    # /etc/fstab: static file system information
    #
    # <file system>        <dir>         <type>    <options>          <dump> <pass>
    none                   /dev/pts      devpts    defaults            0      0
    none                   /dev/shm      tmpfs     defaults            0      0
    
    
    /dev/cdrom /mnt/cdrom   iso9660   ro,user,noauto,unhide   0      0
    /dev/cdrom1 /mnt/cdrom1   iso9660   ro,user,noauto,unhide   0      0
    /dev/dvd /mnt/dvd   udf   ro,user,noauto,unhide   0      0
    /dev/fd0 /mnt/fd0   vfat   user,noauto   0      0
    /dev/sda8 / ext3 defaults 0 0
    I rebooted and then it gave me the login prompt without any error.
    Now i want to know whether i have handled this problem in a good way or is my solution is not the better one.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie reiko's Avatar
    Join Date
    Aug 2007
    Location
    Chennai, India
    Posts
    105
    Well OZAR u havent replied to my thread pls anybody help me out to fix this problem!!!!!!!!!

  6. #5
    Linux Engineer
    Join Date
    Nov 2004
    Location
    home
    Posts
    796
    The only change you made is not to check the filesystem on boot. Apparently this was causing the problem. It sounds like it works fine now that it gets past that check. You might want to run fsck yourself to check the fs, and see if it works for you manually instead of automatically.

  7. #6
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Now i want to know whether i have handled this problem in a good way or is my solution is not the better one.
    I really don't know why you are getting the file system error.

    My own fstab entry for the root partition looks like this:

    Code:
    /dev/sda6   /            ext3          defaults                0      1
    ...and I've never gotten that error.

    Maybe someone else will chime in with some clue as to where the error is coming from. In the interim, I'll post back if it should come to me.
    oz

  8. #7
    Linux User infoshirish's Avatar
    Join Date
    May 2007
    Location
    Pune, India
    Posts
    397
    Hello rieko,

    Well you wont get that error but i guess it exists. As when you edit fstab for zero then fsck won't check the filesystem. If its one then by default it always checks for filesystem though. Ozar is not getting any errors as might be his filesystem is working perfectly fine. According to me you need to check for bad blocks. But it will eat your huge time.

    Also you can try tihs:-
    Code:
    Code:
     1. Boot to single user mode (maintenance mode) and give root pasword.
      2. Manually run fsck -y.
      3. Remount the file system as read/write (mount -n -o remount,rw /).
      4. Reboot the system to run level 2.
    Also one strange thing i saw in your case for the outputs of df -h and fdisk /dev/hda Is it possible that it shows sda for df- h and hda for fdisk?
    Anyways do update us.
    Regards,

    who |grep -i blonde |
    date; cd~; unzip; touch;
    strip; finger; mount; gasp;
    yes; uptime; umount;
    sleep

    Newbie clicks
    http://www.linuxforums.org/forum/lin...ead-first.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •