Find the answer to your Linux question:
Results 1 to 2 of 2
I was installing kdemod, and I was tweaking my xinitrc file to work. I got an error message from kdemod that it couldn't find the command 'kdeinit'. I tried startx ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Location
    Middle of No Where.
    Posts
    27

    sudo died when I ran kdemod


    I was installing kdemod, and I was tweaking my xinitrc file to work.
    I got an error message from kdemod that it couldn't find the command
    'kdeinit'. I tried startx again, and after trying to start the server it
    logged out. When I logged in sudo didn't recognize ANY command. i.e.

    username@host ~$ sudo ls
    sudo: ls: command not found
    I reinstalled sudo with a new sudoers file and changed the 'root' to my username,
    but it didn't work. Any idea what's wrong?

    EDIT: 'halt' didn't work either.

    EDIT2: Today I booted linux and I ran 'cd' which should take me to the home directory. I would think that that means that 'HOME' isn't set right. Isn't 'HOME' set by bash or '.bashrc'?

  2. #2
    Linux Newbie Tutku's Avatar
    Join Date
    Jul 2007
    Location
    Izmir / Turkey
    Posts
    167
    for getting root privileges your user has to be in "wheel" group. Make sure that your user is element of "wheel" group.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •