Find the answer to your Linux question:
Results 1 to 4 of 4
Hey there, I've burned the core iso from a official archlinux mirror, but I keep getting this message when I'm trying to boot from the CD: Boot CD-ROM Type: Non-Emulation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    [SOLVED] Problem with grub on installation


    Hey there,
    I've burned the core iso from a official archlinux mirror, but I keep getting this message when I'm trying to boot from the CD:
    Boot CD-ROM Type: Non-Emulation Booting
    Loading stage 2
    And a split second later I get this:
    GNU GRUB version 0.97 (639k lower/523200k upper memory

    [Minimal BASH-like line editing is supported.
    For the first word, TAB lists possible command
    completions. Anywhere else TAB lists the possible
    completion of a device/filename.]
    grub>
    I googled around the issue, and found this post.
    The guy says that his bios won't support grub, but I have grub installed as we speak, plus I had already installed arch before on this machine, with this very iso. It's not a problem with the CD as I've tried to boot it on another computer and it works fine. Can I boot Archlive from this shell? With what commands? What's causing the issue?
    I hope someone helps me solve this quickly as I need my archsystem up and running as soon as possible
    Thanks

  2. #2
    Linux Newbie sdimhoff's Avatar
    Join Date
    Jan 2007
    Posts
    191
    Since you are booting from the CD I'm not sure how much help this link will be. You may be able to modify the commands from that post so that they point to the kernel image on the cd (not on the hard drive like the post does). But check some more on google, I searched for "booting from a grub shell"

    Booting from grub shell | Chris Searle

    As of right now that would be my best guess. I haven't ever run across a system where the bios conflict with grub, but I suppose anything is possible.

    Good luck!
    Linux since: 2001
    Gentoo since: 2004
    - - - - - - - -
    Translation:
    I fix things until they break.

  3. #3
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    I thought syslinux was used for CDROM ... on my Arch CD there does not appear to be a grub config, but there is an isolinux.cfg which contains ...
    Code:
    prompt 1
    timeout 300
    display boot.msg
    F1 boot.msg
    F2 options.msg
    default arch
    label arch
    kernel vmlinuz
    append initrd=initrd.img rootdelay=5
    label lowmem
    kernel vmlinuz
    append initrd=lowmem.img rootdelay=5
    You said you had used that ISO to install before ... are you using CD-R rather than read/write media?

  4. #4
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    I've solved it the hard way I've installed the system today with the 2008.03 CD. Don't know if your methods would have worked, but thanks anyway

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •