Find the answer to your Linux question:
Results 1 to 1 of 1
I am an Arch newbie. In Ubuntu recognition has been almost automatic. In /etc/rc.conf : Code: DAEMONS=(syslog-ng network netfs crond hal openntpd alsa cups gdm). and in Modules !usblp On ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    5

    [SOLVED] Printer problem with HP F4100 Desktop usb printer


    I am an Arch newbie. In Ubuntu recognition has been almost automatic.

    In /etc/rc.conf :
    Code:
    DAEMONS=(syslog-ng network netfs crond hal openntpd alsa cups gdm).
    and
    in Modules !usblp

    On bootup start up of these daemons is indicated.

    When I go to Manage Printers Cups under printers I get no printers.

    The printer is indicated in lsusb.

    lsmod shows
    Code:
    usbcore 154032  4 usbhid,uhci_hcd,ehci_hcd
    dmesg does not refer to any printer. Taking out !usblp from hardware modules, I
    Code:
    get usblp0: USB Bidirectional printer dev 3 if 1 alt 0 proto 2 vid 0x03F0 pid 0x7E04
    usbcore: registered new interface driver usblp
    What do I need to do to get my HP 4100 Series Desktop working?
    Thanks.
    Edit: I had tried to install pyqt several times, but message was corrupted files. I changed repositories, and downloaded pyqt successfully. Able to run hp-toolbox and install printer. Thanks
    Last edited by ubume2; 12-03-2009 at 11:18 PM. Reason: solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •