Find the answer to your Linux question:
Results 1 to 3 of 3
I have just been bitten by the Arch bug...It is a fantastic distro which gives complete control to the user. I am a newbie but quite willing to experiment I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    19

    [SOLVED] Autofs and Alsa


    I have just been bitten by the Arch bug...It is a fantastic distro which gives complete control to the user. I am a newbie but quite willing to experiment

    I have 2 problems

    1. I have an old P4 latop (DELL inspiron 8600) with an IDE HDD...Devices show as /dev/hda i/o /dev/sda...My DVD ROM drive is also detected at boot as hdc...I am able to manually mount the drive but cant get it to start automatically

    I have tried various methods like ide-scsi emulation / Autofs etc but in vain..I have followed Arch Wiki's instruction exactly to set up autofs but on boot Autofs Daemon shows as "FAIL"...I have added autofs module to /etc/rc.conf under modules...Modified /etc/nsswithch.conf and appended automount: files...The automaster and auto misc seems to be ok...
    auto.master

    /auto /etc/autofs/auto.misc --timeout=10

    auto.misc

    cd --fstype=auto ro,nosuid,nodev :/dev/hdc

    I have tried editing mkinitcpio to include ide_core in modules and appending hdc=ide-scsi at te end of kernel line in GRUB...

    No success

    I have 3 other distros ---openSUSE,Mint 9 and PCLinux OS and everything works out of the box...The other distros seem to convert "Hda" notation to "sda" (probably due to scsi emulation)..I tried copying the autofs portion from these distros but the others seem to be different..

    In /etc/rc.conf, I have HOOKS="base udev dbus autofs hal ide scsi pata sata filesystem"

    I have installed autofs4 module...Also installed cdrkit ....

    I added IDE as without that kernel panics or says unable to read superblock or could be corrupt or something and drops to a root asking to modify the setting

    Also ALSA doesnt get started on its own ...i have to modprobe and set amixer settings as root to make things work

    Pl help..

  2. #2
    Just Joined!
    Join Date
    Oct 2010
    Posts
    19
    I have got the automount working ...The files from cd/dvd is mounting in the desired path..But I dont understand why there is no Icon appearing in Desktop when I insert a CD? For USB it works fine Ehen I insert a USB, icon shows up immly on the desktop... How to enable the same feature for my DVD drive??

    Also I think from Kernel 2.6 , Udev (my ver 2.6.32-lts)gets loaded automatically ...I have currently given HAL in my Daemon options as without that Xorg (ver 1. doesnt get booted.

    Any pointers to achieve my objective...

    My DVD drive is recognized at boot as

    ATAPI CDx Drive ver 5.0

    hdc : ide-cd

    I have IDE drive as mentioned in my post

    ALSA is ok..I read that current ALSA ver is muted by default and we have to manually unmute....It would be nice to have a welcome sound on boot and an exit sound on poweroff though!

  3. #3
    Just Joined!
    Join Date
    Oct 2010
    Posts
    19

    Solved

    Automount is SOLVED ...I installed ivman from AUR.....

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •