Find the answer to your Linux question:
Results 1 to 7 of 7
Yeah, so I am trying to install Arch linux (Which I have done before) and I installed it successfully two different ways, my normal way (With a boot, /, swap, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2010
    Posts
    4

    [SOLVED] New Arch install has trouble booting


    Yeah, so I am trying to install Arch linux (Which I have done before) and I installed it successfully two different ways, my normal way (With a boot, /, swap, and home partition) and once by following the idiot guide (/, var, swap, and home partitions), as well as trying both procedures in both the x86_64 and i686 net installs of Arch, and I end up with the same problem. Essentially, when I boot my system, I get past Grub, and I get the to point where it says: "Waiting for UDev uevents to be processed" then my screen goes totally black and my computer seems to stop sending any kind of signal to my monitor. This is where it gets weird, because at this point, I appear to still have full access to the Arch OS, which I have tested by doing this:

    "reboot"
    "reboot"
    Nothing happens here
    "root"
    "Password"
    "reboot"
    At this point, my computer reboots. I've looked around for the past few days and can't find anything definitive about this, except that it might have something to do with the fact that I am using an Nvidia card.

    Comp Specs:
    Nvidia 6150LE (On-board graphics)
    AMD Athlon 64 4000

    Well, that's likely all that would be a problem really at this point. Let me know if any more information is needed. Thanks.

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Are you trying to boot to a terminal ?

    Boot from a live CD and check you have settings in inittab to boot to runlevel 3. Try disabling automatic module loading in rc.conf. If you still have problems booting to a prompt then also try chrooting into your install and update mkinitcpio and put modules to access your filesystems in modules section and remove udev from hooks section then either use pacman to reinstall the kernel or manually run mkinitcpio. Example entries I have in mkinitcpio.conf below

    Code:
    MODULES="pata_acpi pata_ali ata_generic sata_via sd_mod sr_mod ext4 ext3 reiserfs"
    Code:
    HOOKS="base autodetect keymap"
    Ed: I have not encountered the issues you have but started tinkering with mkinitcpio to improve boot times
    I still have module autoloading in rc.conf, I just don't need udev to detect stuff twice .
    Last edited by Jonathan183; 10-31-2010 at 10:14 PM.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome to the forums!

    So far as I know, the nVidia graphics shouldn't be a problem but you might check this wiki page in case it has anything to do with the nouveau drivers that are now loaded by default:

    https://wiki.archlinux.org/index.php/Nouveau

    I too use nvidia drivers and have never run into the issue you describe, but I don't have on-board graphics.

    If it helps any, here's what I have in the rc.conf and mkinitcpio.conf files running 64-bit Arch with Gnome:

    rc.conf:

    Code:
    MOD_AUTOLOAD="yes"
    MODULES=(!usblp)
    DAEMONS=(syslog-ng network !netfs crond rpcbind fam dbus hal cups alsa)
    mkinitcpio.conf:

    Code:
    MODULES="ahci"
    HOOKS="base udev autodetect pata scsi sata filesystems"
    oz

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2010
    Posts
    4
    Heyo, sorry it took so long to get back for this, but I've been busy. Anyways: Disabling Udev (By removing it from the HOOKS list) seems to stop my computer from booting at all, giving me some error about not seeing sda1 (Where the boot folder is)

    I had my doubts about the Nvidia being the problem, since from my understanding, Nvidia is far better supported than, say, ATI, bu tI figured I would mention it anyways, I don't think I saw anything on that wiki page about the drivers.

    I haven't yet had a chance to try the other suggestions, but will probably get to them tomorrow and I'll get back to you.

  6. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    I second the advice to setup a chroot environment from the live CD. (I assume the live cd is booting ok?)

    Guide for setting up the chroot.

    I would do a full update there.

    If nouveau is the problem, I would wager it's because of kernel mode setting. You can try disabling it by adding
    nouveau.modeset=0 to the kernel line of grub.conf at boot or
    Code:
    options nouveau modeset=0
    to /etc/modprobe.d/modprobe.conf and rebooting.

  7. #6
    Just Joined!
    Join Date
    Oct 2010
    Posts
    4
    Ugh, I apologize profusely for this taking so long to get back on this, this is just the first free time I've had in weeks to actually attempt anything on this (Midterms, etc.). Anyways, after quite some time of trying to fix this, I got frustrated and decided to install linux for morons. Well, after installing that, I got the same problem there as well. Turns out, it was my video card that was the problem, because after installing a broken (It garbles graphics) graphics card, I rebooted and ubuntu booted just fine. Come back and boot arch, it also boots just fine. So yeah, not really a solution since I still don't have another graphics card, but maybe this could help with diagnostics? I'll try messing with nouveau now and see if I can get it to boot with me normal video card.

  8. #7
    Just Joined!
    Join Date
    Oct 2010
    Posts
    4
    Victory! Ended up using that junky video card just long enough to install the nvidia proprietary drivers and it fixed my problem. Thanks for all your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •