Find the answer to your Linux question:
Results 1 to 7 of 7
I'm new to Arch, so be kind When I start X, it doesn't output the right screen size to my monitor so there is about an inch and a half ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    28

    [SOLVED] Xorg not getting screen size right


    I'm new to Arch, so be kind

    When I start X, it doesn't output the right screen size to my monitor so there is about an inch and a half of black on the right side that my mouse can't get in to.

    No problems installing Xorg.
    Problem showed in the desktop environment as well as plain old xorg, so it can't be the DE.
    Looked in /etc/X11 for .conf files, but the only ones there were for input devices.
    No graphics card. Just the built-in VGA.

    Any help?

  2. #2
    Just Joined! Anspliff's Avatar
    Join Date
    Nov 2010
    Location
    Houston, Tx
    Posts
    35
    Did you install this from the Arch Wiki Article? There is a Section in that labled "Display Size and DPI" that may be helpful.

  3. #3
    Just Joined!
    Join Date
    Apr 2010
    Posts
    28
    Thanks, I've been looking it over.

    I have Ubuntu running on the same machine. Could I possibly use the settings in xorg there (screen size, resolution, etc) to set up xorg on Arch?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Anspliff's Avatar
    Join Date
    Nov 2010
    Location
    Houston, Tx
    Posts
    35
    That will work for the most part just make sure the driver being called is correct. I have used configured xorg.confs from other distros before.

  6. #5
    Just Joined!
    Join Date
    Apr 2010
    Posts
    28
    Are those the input drivers or the video drivers?

    UPDATE:
    Got an xorg.conf for my ubuntu os, and it looks like the only difference between it and Arch's autogenerated xorg.conf is the driver- Arch uses a generic driver, while ubuntu uses "intel". I'll look at that driver and see how to get one on Arch. The Arch wiki (which is freakin' sweet, by the way) recommends 'xf86-video-intel' or something like that.
    Last edited by fishin4guitars; 12-04-2010 at 04:05 AM. Reason: Update

  7. #6
    Just Joined! Anspliff's Avatar
    Join Date
    Nov 2010
    Location
    Houston, Tx
    Posts
    35
    Mostly the Driver. If your using a different driver then what was in Ubuntu or if your just using base vesa drivers in xorg you should be fine.

    (Mine)
    Code:
    Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            Option      "Monitor-CRT1" "0-CRT1"
            BusID       "PCI:1:0:0"
    EndSection

  8. #7
    Just Joined!
    Join Date
    Apr 2010
    Posts
    28
    Well, turns out switching drivers was the right thing.
    I've got full screen width and full resolution.

    Thanks for your help (again), Anspliff.

    Thread: Solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •