Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Twm is the default X window manager. It's weird that openbox isn't starting if you did the above. Can you post your ~/.xinitrc file?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651

    Twm is the default X window manager. It's weird that openbox isn't starting if you did the above.

    Can you post your ~/.xinitrc file?

  2. #12
    Just Joined!
    Join Date
    Dec 2010
    Posts
    33
    Quote Originally Posted by reed9 View Post
    Twm is the default X window manager. It's weird that openbox isn't starting if you did the above.

    Can you post your ~/.xinitrc file?

    I've tried it like this, and without the 'ck-launch-session' parameter.

    #!/bin/sh
    #
    # ~/.xinitrc
    #
    # Executed by startx (run your window manager from here)

    # exec gnome-session
    # exec startkde
    # exec startxfce4
    exec ck-launch-session openbox-session

  3. #13
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    The ck-launch-session is so you can attach to a consolekit session. It has no bearing on whether openbox starts, but without it you'll get lots of dbus errors and such.

    But I'm at a loss if you have the above at /home/whoisthere/.xinitrc, openbox is installed, and you're typing startx to begin.

    What happens if you start it like this
    Code:
    xinit /usr/bin/openbox-session

  4. #14
    Just Joined!
    Join Date
    Dec 2010
    Posts
    33
    Quote Originally Posted by reed9 View Post
    But I'm at a loss if you have the above at /home/whoisthere/.xinitrc, openbox is installed, and you're typing startx to begin.
    Unlike the Debian net install, which contains an existing base on the disc. Arch seems to have downloaded everything fresh off the net. The Debian text installer walked me through setting up administrative, and user accounts with passwords. Arch's didn't seem to have that in the setup disc.

    The command line shows "@myhost" with a prefix of "root" as the login. I'm not even asked for a password.

    But.... I have .xinitrc in '/', and not '/home/USER_PROFILE'. I actually have Arch sharing '/home' with Debian.

    Quote Originally Posted by reed9 View Post
    What happens if you start it like this
    Code:
    xinit /usr/bin/openbox-session
    It loads like I thought it initially would.

  5. #15
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Got. You should probably read through the beginner's guide.

    The host is set in /etc/rc.conf, as are daemons (which Debian starts automatically once installed), basic network settings (if you aren't using a network management program), and kernel modules (mostly autodetected, but you can blacklist or force load them here).

    To set up a user run
    Code:
    adduser
    You'll probably want the same username as your Debian install if you're sharing the home partition.

    Arch does not do much of anything for you, unlike Debian or most other distros. You have full control to set it up as you like. You will need to consult with the documentation to get things set up though.

  6. #16
    Just Joined!
    Join Date
    Dec 2010
    Posts
    33
    You should probably read through the beginner's guide.
    Okay, I get that I need to read the docs more, but I tend to forget stuff that I'm not directly applying at the moment.

    I think the OT is solved though. Thanks for the thorough help.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •