Find the answer to your Linux question:
Results 1 to 4 of 4
Ok so I was using Ubuntu for some time now and I decided to switch to Arch because it is more configurable and such, I managed to install it properly ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2010
    Posts
    5

    [SOLVED] WIreless help


    Ok so I was using Ubuntu for some time now and I decided to switch to Arch because it is more configurable and such, I managed to install it properly from the core iso and selected all the packages just in case, once installed I am succesfully using XFCE4 but the problem comes to the wireless, I've been searching around for a few days on how to get the wirless going and the furthest I've come to doing is turning on my wireless. I can tell its on because my laptop (HP Pavilion dv5-2135dx) has a little LED for the wirless and the commando that got it turned on was:
    sudo dhcpcd wlan0
    But this is my terminal output
    dhcpcd[3258]: version 5.2.9 starting
    dhcpcd[3258]: wlan0: waiting for carrier
    dhcpcd[3258]: timed out
    When I run iwconfig this is what I get

    lo no wireless extensions.

    eth0 no wireless extensions.

    wlan0 IEEE 802.11bgn ESSID:"INFINITUMc2d5"
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:on

    Before I got this turned on I had my head spinning wondering how to identify my driver and download it and stuff, and when I ran iwconfig my wlan0 would display as off.

    I am VERY new to this sudden change from Ubuntu to Arch, so I need some guidance on how to make sure my wireless is working properly and how to connect to my wireless adress wich has a key but obviously I know it.
    Do I have to modify some configuration files ?
    If so wich ones?
    I had tried to use compat wireless for the driver stuff but whenever I tried to run the shell scripts I would get this kind of output

    chmod +x ./scripts/driver-select
    chmod: cannot access `./scripts/driver-select': No such file or directory

    I am such a noob but at this but I would REALLY apreciate some help here :/
    Until then I'm on ethernet and I REALLY don't want to switch back to Ubuntu or Windows

    Help is appreciated

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    First thing, what is your wireless chipset. Please post the output of
    Code:
    lspci -vnn | grep -a4 -i net

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Come to think of it, are you wanting to manage the wireless from the console? Or do you want to use a network management program like wicd? (Which also has a console interface.) Or Arch's netcfg scripts?

    Also, does your wireless connection use any security, WEP or WPA? If so are you putting in the passhprase with iwconfig for WEP, or using wpa_supplicant for WPA? Is the essid above, INFINITUMc2d5, correct?

  4. #4
    Just Joined!
    Join Date
    Dec 2010
    Posts
    5

    Solved

    After franticly looking around for a solution I figured out that all I had to do was run
    dhcpcd wlan0
    Once my wlan was up I ran
    sudo ifconfig wlan0 up
    then
    sudo iwlist wlan0 scan
    that showed me the networks available and mines was displayed.
    Then I ran
    sudo iwconfig wlan0 essid "INFINITUMc2d5" key xxxxxxxxxx
    Afterwards I ran sudo dhcpcd wlan0
    And my output would finally state that I hooked the signal.
    I hope my method helps anyone viewing this, the thing is I was making things harder than they really were.
    Thanks anyways for the help, my wireless driver may have been loaded from a start since the Arch wiki stated that the ath9k driver has been included in the kernel since a few versions back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •