Find the answer to your Linux question:
Results 1 to 2 of 2
I have PERL 5.10 installed in my linux i686 machine. I tried running sims, A perl script used in regression of OpenSPARC T1 core. It returns the following error /usr/bin/perl: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2010
    Posts
    2

    Exclamation undefined symbol: Perl_Tstack_sp_ptr


    I have PERL 5.10 installed in my linux i686 machine. I tried running sims, A perl script used in regression of OpenSPARC T1 core. It returns the following error

    /usr/bin/perl: symbol lookup error: ~/OpenSPARCT1/tools/perlmod/Linux-i686/auto/Bit/Vector/Vector.so: undefined symbol: Perl_Tstack_sp_ptr

    The reason seems to be due to be using PERL5.8.7 when the script was compiled. The reasons are specified here

    "bugs.archlinux.org/task/9078"


    Can anybody point me in the right direction as to what exactly is to be done. I tried reinstalling perl 5.8.7 but that dint seem to solve the problem. I dont understand what "recompiling the library using perl 5.10" that is mentioned in the above mentioned link.

    Thanks

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Presumably, this should be fixed soon with updated packages in the Arch repositories. Rebuilding against perl 5.10 just means compiling the packages using the 5.10 development files. Arch doesn't split out dev packages from the regular packages as most distros do, so you should have all the necessary stuff on your system already. (Assuming you also have installed the base-devel group.)

    You can quickly recompile packages using ABS.

    Alternately, some 3rd party package managers will allow you to build from source, I'm thinking bauerbill in particular.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •