Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hello everyone, This is my first post and it should be quite one at that. I have been trying to get Arch ( as well as nearly every other flavor ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2011
    Posts
    8

    Unhappy Fujitstu Lifebook '98 Headache


    Hello everyone,

    This is my first post and it should be quite one at that.

    I have been trying to get Arch ( as well as nearly every other flavor of linux you can imagine) to install on a Fujitsu LifeBook S-4510 that I suspect is a 1998 or 1999 model. It has a 400 mhz PIII with 128 MB SDRAM. It'll run Win 98, Win 2k and several live-only linux distros (debian inparticular) well. Though I have tried many distros, I wish to use arch for fairly obvious reasons.

    However the problem is with mounting the CD during the install process. When I attempt to run the installer it indicates it is unable to read the source media, and while it's still booting up I get a nice stream of error messages on sr0 saying the device cannot be read. Now it does this for every bootable linux disk so I expect it is something in the hardware that the kernel doesn't agree with.

    I have tried:
    1. getting files from a external USB hard disk set up according to arch recommendations in conjunction with the CD. Install progresses to the point of login then fails reporting it is unable to access a shared library in /lib/
    2. burning the disk at the slowest possible speed (4x) had no effect other than to consume lots of disks
    3. verifying disk integrity
    4. perform machine integrity tests,and as I said the machine is totally functional
    5. playing with BIOS settings for CDROM has no effect
    6. setting a symbolic link to /dev/sr0 to match what the installer is looking for and I get the same errors I mentioned above and dumped right back to rmfs shell

    The point of this enterprise was to prove a point about how wasteful modern OS's can be as well as the versatility of linux. The joke appears to be on me thus far. However short of anything anyone here can suggest I am considering:

    1. Trying a PXE boot, which I've never done before
    2. Installing freeBSD or some other BSD (which apparently works on toasters)
    3. Giving in and keeping the win2k partition it has already
    4. Attempting to discover its terminal velocity by experimental trials

    So, forgive the lengthy post but I did have a lot to say. Is there ANYONE who can help me?

    Thank you in advance!
    Last edited by methesula; 06-09-2011 at 05:44 AM. Reason: changed model number to correct one

  2. #2
    Just Joined!
    Join Date
    Jun 2011
    Posts
    8

    Specs

    Sorry for the double post but I have the actual specifications of this machine now. I'm not allowed to post a url yet, but one were to do a google search for:

    fujitsu lifebook s 4510

    and click on the cnet link, one would find a complete hardware spec.

  3. #3
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Have you checked minimum hardware requirements for Arch? Googled fujitsu lifebook and it seems the maximum RAM is 128MB.
    playing with BIOS settings for CDROM has no effect
    ??You have the CD drive set to first boot priority? Not sure what you mean by the statement above.

  4. #4
    Just Joined!
    Join Date
    Jun 2011
    Posts
    8

    What's worked so far

    Hello

    1. The best I've found is that 128 MB is the minimum. However, certain live disc spins of distros like debian have worked on this machine (just without being installable) so I have no fear of it's ability to handle something as skinny as arch.

    2. By 'bios settings' I only meant that this CD-ROM drive was fairly old and had few configurable settings that I thought might have potentially affecting its operation. Not so much.

    However I've since tried Debian 2.2, which was based on the 2.4.7 kernel, and that has worked. I have no intention of using it because it's laughably out of date (as well as frustratingly old fashioned), and I'd really prefer a more modern distro (if not a contemporary or full blown one).

    So here is the question I have now; how much of modern linux installers, which I know little about, is tied to the kernel? I suspect the reason why deb 2.2 worked was either the kernel or the nature of the installer. If it's the kernel, then I'm sunk. However, it it's something that can be avoiding by using a different method of installation (i.e. installable live disk) then maybe it can be done.

    However, note that the current defacto installer type, which loads a shell on boot and then attempts to mount the drive again which always fails for me regardless of the distribution on this machine. Yet, the live-only debian live CD worked (its inability to probe or detect my hard disk may or may not been a kernel limitation on the old hardware, I don't know). Deb 2.2 worked, and I believe it is a different either in loader style or in format of the disk, perhaps both.

    (I'd love to share with you the ftp site I got the Deb 2.2 iso's, but as the law of the land states...I can't. But if anyone want to glance at them and possibly enlighten me you'll find it at "mirror.klabs.be debian-cd potato 2.2_rev7 iso i386" just with a few more slashes and an http protocol in the front. I believe the deb 2.2 discs are all BIN formats)

    Thanks!

    -TC

  5. #5
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,037
    Since you have 128MB of ram . Maybe change gears and look at Tiny Core Linux (it is current) or Slitaz.

    Both should run and install quite easy. Suggestion: Make a 512MB swap partition before trying a install with something like Gparted from live cd session first.

    I am not familiar with the Arch installer. Ozar and a few other members here are Arch users and may yet reply also.

    Edit: is this a i486 machine because you have kernel issues?

    Second edit

    If it is i486 : # antiX-M11-base-486 LinuxTracker This antiX kernel version is for i486 machines. As far as I know. Arch is only in i686 . I don;t think Slitaz will work on i486. Not sure about Tiny Core though.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  6. #6
    Just Joined!
    Join Date
    Jun 2011
    Posts
    8

    Alternatives and their shortcomings

    Hello,

    1. I've actually tried Slitaz on this machine and I can't even get it to boot. The problem appears to be something in the boot loaders modern linux live CD's use. What it is, I don't know yet. Tell me if this other alternative is different then I'll burn a CD.

    2. I've set up a swap or two. haha. As I said, I have Debian 2.2 on it, but I have zero interest in keeping it for a variety of reasons.

    3. it's not a 486, not even close. It's a 686 Pentium 3, albeit the first generation thereof (Katmai). It's rockin 400mhz.

    As I said before, I got a newish version of Debian (NOT 2.2) that was LIVE ONLY running on this without any effort at all. I just can't install it. I got it from live.debian.net. This is why I came to this community as my knowledge of linux ends there. I suspect this is a packaging issue, so to speak, not a kernel one.

    So, any other ideas?

  7. #7
    Just Joined!
    Join Date
    Jun 2011
    Posts
    8
    UPDATED STATUS

    (And for those of us at home just tuning in...)

    Computer: Fujitsu LifeBook S-4510 circa 2000. Has a 400mhz PIII (686) processor with 128MB RAM

    Goal: Install a reasonably modern and modest Linux system, ideally arch

    OS's/OS installers/boot loaders that have worked so far:

    (NOTE: BOOTLOADER HERE IS NOT LILO/GRUB BUT WHAT'S LOADING VMLINUZ, ETC DURING BOOT)

    -Debian LIVE CD 6.0.1 - boots without a problem; cannot install this to hd. Possible hardware issue since apparently cannot detect and mount HD or CD (take that with a grain of salt). However, it shows that a modern kernel works. Image from live.debian.net

    -Debian 2.2 (Potato) - Installs from downloaded images burned to CD's. Way too outdated for my goals but is a functional linux system. Images from mirror.klabs.be/debian-cd/potato/2.2_rev7/iso/i386/

    -Windows 2000 - Just as a control, this works perfectly off of a 12x burned CD-R so the CD-ROM drive can be eliminated as a weak point. It's 24x anyways.

    Non-working OS/OS installers/boot loaders:
    -Arch
    -Fedora
    -Xubuntu, Lubuntu
    -Slitaz
    -Puppy

    Symptoms: Initial boot loader loads kernel fine but cannot mount CD during installation.
    In Arch, I get a stream of read errors on sr0, the other vary but do basically the same thing.

    Working theory:

    The way that the older OS installers are set up use a single binary image instead of loading the kernel and then mounting a filesystem on the CD. It seems this machine is unable to perform this mount operation. Thus the Live CD working makes since because it's a one shot deal and is just one binary boot track. It also explains why the initial loaders have worked on the otherwise nonfunctional OS's, since any boot sector needs to be binary. As to what causes the mount to fail, I don't know; that's why I am here. I don't think it's the limited memory, though that depends on how the installer is written. In any case, I think what I need to make this work is an agreeably low footprint OS that offers a straight up binary installer. Clearly if I can run Debian 6.0.1 live on this the machine isn't just too geriatric for a modern kernel and OS.

    So, does anybody know of an Arch installer that is totally binary or of another light weight distro with one?
    -TC

    And we'll be right back after this commercial break!
    Last edited by methesula; 06-11-2011 at 12:30 AM.

  8. #8
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,037
    -Debian LIVE CD 6.0.1 - boots without a problem
    Hmmm, Ok. Now Since i686 has been established. Any 32 bit kernel should boot OK. Since Debian live boots ok.

    I'm not familiar with Debian Live. Is there a way you can see what boot screen shows in Debian like

    Code:
    kernel /boot/vmlinuz-2.6.36-1-mepis-smp root=/dev/sda1 nomce quiet nosplash nouveau.modeset=0 vga=791
    Paying attention to everything after root=./dev/sda1 like

    Code:
    nomce quiet nosplash nouveau.modeset=0 vga=791
    Just posting mine as a example. Maybe by changing boot code at boot screen . You can get Slitaz to boot (crosses fingers).

    Maybe something like acpi=off or something is making Debian Live boot OK. Just guessing here in the desert though.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  9. #9
    Linux Guru rokytnji's Avatar
    Join Date
    Jul 2008
    Location
    Desert
    Posts
    4,037
    Arch sro errors are cdrom errors I think also.
    Linux Registered User # 475019
    Lead,Follow, or get the heck out of the way. I Have a Masters in Raising Hell
    Tech Books
    Free Linux Books
    Newbie Guide
    Courses at Home

  10. #10
    Just Joined!
    Join Date
    Jun 2011
    Posts
    8

    CD Errors

    I really wish it was just the CD, but unfortunately I've eliminated that.

    I did this by:
    1. burning discs at the lowest speed my burner could support (4x)

    2. Using fairly high quality media (sony)

    3. Tried more than one copy, and always used them fresh out of the burner.

    4. Other os's have installed using this discs.

    So, it's some other little bugger =/

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •