Find the answer to your Linux question:
Results 1 to 2 of 2
Hello everyone. Before I begin, just want to let everyone know that I have searched these forums and many others and haven't found any solutions specific to the issue I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    m3z
    m3z is offline
    Just Joined!
    Join Date
    Jul 2011
    Posts
    1

    Angry Arch Linux install issues - eth0 no such device - Atheros ethernet


    Hello everyone. Before I begin, just want to let everyone know that I have searched these forums and many others and haven't found any solutions specific to the issue I am having. I have also read the arch linux wiki on installation but to no avail.

    I have a fresh Arch linux install (latest version as of today) on my Toshiba Satellite L755.

    when doing lspci, I have the following for network and ethernet:

    Code:
    Network controller: realtek semiconductor co., ltd. device 8176 (rev 01)
    ethernet controller: atheros communications ar8152 v2.0 fast ethernet (rev c1)
    Originally I was having issues getting wireless setup, so I said screw up and hoped that getting wired would be an easier route but apparently its just as frustrating.

    Here is my rc.conf for networking:


    Code:
    eth0="dhcp"
    INTERFACES=(eth0)
    
    gateway="default gw 192.168.1.1"
    ROUTES(!gateway)
    Have also tried this with eth1, wlan0, wlan1, ath1, ath0.

    If I do a modprobe atl1c or a modprobe ath9k, it will go without an error, but then if I try and do a ifconfig eth0 up I get a eth0: unknown interface: No such device.

    Also, I only seem to have loopback up. Doing an ifconfig gives me just lo.

    Sorry for the long post. If you need more information, let me know. Thank you in advance.

  2. #2
    Linux Engineer RobinVossen's Avatar
    Join Date
    Aug 2007
    Location
    The Netherlands
    Posts
    1,429
    ifconfig -a gives nothing I guess.
    What I advice (and always do if I have a issue like this) is to try.
    to setup
    Code:
    #Static IP example
    #eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
    #eth0="dhcp"
    INTERFACES=(!eth0 !wlan0)
    
    # Routes to start at boot-up (in this order)
    # Declare each route then list in ROUTES
    #   - prefix an entry in ROUTES with a ! to disable it
    #
    gateway="default gw 192.168.0.1"
    ROUTES=(!gateway)
    that. And install wicd using a pendrive.

    But this will most likely not fix your issue.
    And you MIGHT find your answer here: https://bbs.archlinux.org/viewtopic.php?id=80773

    Sorry I couldn't really be helpful at all, but I hope I have helped just a tiny bit.
    New Users, please read this..
    Google first, then ask..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •