Find the answer to your Linux question:
Results 1 to 9 of 9
Recently installed arch, got it to boot and everything. I created a user, but every time i try to log in slim with a regular (non root) user, the screen ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2011
    Posts
    16

    Cant login with slim


    Recently installed arch, got it to boot and everything. I created a user, but every time i try to log in slim with a regular (non root) user, the screen goes black, and comes back to the slim login screen.

    Root user, however, is able to boot up and do as it pleases.

    any ideas guys?

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,102
    How did you create the user?
    Commandline? Other method?
    What/who is slim?

  3. #3
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    I've not used Arch, so this may not apply...
    When you created your regular user account, what command did you use?
    adduser will not always create a home directory, which means you wouldn't have a default profile with which to login.
    useradd, however, creates a home directory, including a .bashrc file, config files, etc...
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,307
    Quote Originally Posted by yancek View Post
    What/who is slim?
    Slim is a cool lightweight desktop login manager (replacement for GDM).

    @elohelomg,

    SSH into (or use Virtual Terminal - Ctrl+Alt+Fwhatever) your arch box as root user and tail /var/log/secure

    Then log in via Slim as regular user and see what it reports (also check /var/log/messages)

  5. #5
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    check contents of /etc/passwd and /etc/shadow for entries for the user you created
    after that check if the home area indicated in /etc/passwd for your user exists ... use ls -l to check ownership of the home folder and the shell being run by the user ...
    example /etc/passwd entry
    Code:
    jonathan-user:x:1001:100:,,,:/home/arch/jonathan-user:/bin/bash
    entry for user jonathan-user with home area /home/arch/jonathan-user and shell /bin/bash

    ... you may have screwed X by login to gui as root

  6. #6
    Just Joined!
    Join Date
    Jan 2011
    Posts
    16
    After messing around with the ~/.xinitrc, i figured out the problem. I am now able to successfully log into my computer. The new issue that I have is the openbox menu's.

    Using obmenu, i change the settings around, but no changes are made after saving them. i even tried "cd" ing into the actual folder then launching obmenu, no cigar.

  7. #7
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,040
    I tend to use IceWM so can't help much although I use menumaker to create the menu ... which should also work for openbox, it's in the Arch repositories. Glad you got the login bit working ... personally I prefer login at the cli and use startx

  8. #8
    Just Joined!
    Join Date
    Aug 2011
    Posts
    2
    I have the same problem too

  9. #9
    Just Joined! droopysnowmen's Avatar
    Join Date
    Oct 2011
    Posts
    16
    Like elohelomg said, it might be the .xinitrc file.
    Make sure that your home directory contains the file .xinitrc, and that it starts up your desktop environment (whatever it might be)

    I can't post links yet (new user) but search
    "arch linux slim"
    on google and the ArchWiki's page on SLiM should be the first link.

    Look at the "Enabling SLiM" section

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •