Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
So after i installed driver i noticed it went missing so i followed these steps on archWiki https://wiki.archlinux.org/index.php...ss#broadcom-wl Code: # rmmod b43 Code: # rmmod ssb Code: # modprobe wl ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    May 2009
    Location
    Kitchener, Ontario, Canada
    Posts
    206

    So after i installed driver i noticed it went missing so i followed these steps on archWiki
    https://wiki.archlinux.org/index.php...ss#broadcom-wl

    Code:
    # rmmod b43
    Code:
    # rmmod ssb
    Code:
    # modprobe wl
    Code:
    # modprobe lib80211_crypt_tkip
    I added wl to modules in rc.config
    Code:
    MODULES=(wl)
    blacklisted these modules
    Code:
    blacklist b43
    blacklist ssb
    Created the new file /etc/pm/sleep.d/brcm.sh
    Code:
    #!/bin/bash
    # Simple Bash script to fix resume from suspend issues...
    # Place this script in /etc/pm/sleep.d/
    # then chmod +x /etc/pm/sleep.d/brcm.sh
    case $1 in
    hibernate)
    /sbin/modprobe -r brcm80211
    ;;
    suspend)
    /sbin/modprobe -r brcm80211
    ;;
    resume)
    /sbin/modprobe brcm80211
    ;;
    thaw)
    /sbin/modprobe brcm80211
    ;;
    esac
    made the file executable
    Code:
    chmod +x /etc/pm/sleep.d/brcm.sh

    When i type ifconfig "wlan0' is missing still.

    Any ideas

  2. #12
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    First thing I can think of... did you also add lib80211_crypt_tkip to your rc.conf?

    Also...

    Quote Originally Posted by Archwiki
    Warning: This driver is more likely to cause problems than to resolve them. Most of the problems reported by users on Broadcom chips are caused by this driver. Using this is HIGHLY NOT recommended. Before you even think of trying out this one, make sure to try the other drivers first.

    -------------------------------------------------------------------------------------------------------

    Warning: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] does not work with blacklisting b43 and ssb.
    Have you tried other drivers? Perhaps the b43/b43legacy?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  3. #13
    Linux Newbie
    Join Date
    May 2009
    Location
    Kitchener, Ontario, Canada
    Posts
    206
    i havent added lib80211_crypt_tkip to rc.conf

    But the driver i built was the b43legacy since my card is 4311

  4. #14
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    According to the steps that you outlined, you removed the b43 driver ( # rmmod b43 ) and loaded the broadcom-wl # modprobe wl ).
    Am I missing something?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  5. #15
    Linux Newbie
    Join Date
    May 2009
    Location
    Kitchener, Ontario, Canada
    Posts
    206
    oh sorry i thought you meant me manually add it

    i entered everything i typed in my previous post
    Last edited by donaldfarkas; 10-16-2011 at 12:54 PM.

  6. #16
    Linux Newbie
    Join Date
    May 2009
    Location
    Kitchener, Ontario, Canada
    Posts
    206
    i installed AUR (en) - b43-fwcutter-git and AUR (en) - b43-firmware from AUR when i sudo iwlist wlan0 scan i get the msg "wlan0 No scan results"

  7. #17
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Is there a button or several buttons to turn on the Wireless card? This is a laptop, right?


    Try this command and post the results.
    Code:
    rfkill list
    See this link for more info on the rfkill command.
    rfkill - Linux Wireless
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #18
    Linux Newbie
    Join Date
    May 2009
    Location
    Kitchener, Ontario, Canada
    Posts
    206
    I tried that already :S

    Paste #493517 | LodgeIt!

  9. #19
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Could you, once more for us, post the output of lsmod and ifconfig -a?
    By any chance, is your wireless network set to not broadcast it's SSID?
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

  10. #20
    Linux Newbie
    Join Date
    May 2009
    Location
    Kitchener, Ontario, Canada
    Posts
    206
    FINALY GOT IT TO WORK!!!!!!!!!!!!!

    ignore first page of this thread completely


    Fresh install of arch + Openbox
    (I assume you have set up sudo while installing archlinux)

    Code:
    sudo pacman -S base-devel
    AUR (en) - b43-fwcutter-git

    download tarball and PKGBUILD
    navigate to the folder you downloaded it to
    type
    Code:
    makepkg -sci
    once it installs you can delete the 2 things you downloaded so their is no confusion

    AUR (en) - b43-firmware
    download tarball and PKGBUILD
    navigate to the folder you downloaded it to
    type
    Code:
    makepkg -sci
    once it installs you can delete the 2 things you downloaded so their is no confusion

    Code:
    sudo pacman -S wicd wicd-gtk
    Code:
    rc.d stop network
    Stop the other network managers if its a fresh install by following guide you will have "network".Open your /etc/rc.conf go to the bottom where it says DAEMONS

    Code:
    sudo nano /etc/rc.conf
    Code:
    DAEMONS=(dbus !network wicd ...)
    the ! = disables
    also add wicd to DAEMONS


    type
    Code:
    rc.d start wicd
    type
    Code:
    sudo ifconfig wlan0 up
    type
    Code:
    iwlist wlan0 scan
    since its a fresh install and you dont have a notification area
    type
    Code:
    wicd-client -n
    connect to your perferred network


    my first little guide i know its a bit cluttered let me know if there is anything i can improve to make it more readable
    Last edited by donaldfarkas; 10-16-2011 at 09:57 PM.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •